Bug 9800 - axml Intellisense missing
Summary: axml Intellisense missing
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 1.10.x
Hardware: PC Windows
: Normal enhancement
Target Milestone: ---
Assignee: dean.ellis
: 7239 ()
Depends on:
Reported: 2013-01-25 13:59 UTC by Allie Miller
Modified: 2014-07-17 07:17 UTC (History)
15 users (show)

Is this bug a regression?: ---
Last known good build:

Styled (56.38 KB, image/png)
2013-01-25 13:59 UTC, Allie Miller
not styled (44.31 KB, image/png)
2013-01-25 14:00 UTC, Allie Miller

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Allie Miller 2013-01-25 13:59:39 UTC
Created attachment 3287 [details]

The Intellisense and text coloring is missing in the axml files. Instead of following the standard XML editor colouring it seems fixed on a grey background, with dark grey text. 

Attached are two files. 'Not-Styled' is the 'source view' as standard. The 'Styled' screenshot is if I put the content
into a separate xml file and view in Visual Studio.
Comment 1 Allie Miller 2013-01-25 14:00:17 UTC
Created attachment 3288 [details]
not styled
Comment 3 Lucien 2013-02-07 17:45:23 UTC
I am also having this problem. I use ReSharper as well but I have disabled it and this still have not fixed the problem. 

Is their any fix on the horizon?
Comment 5 Miguel de Icaza [MSFT] 2013-05-13 15:19:35 UTC
From Bug 1871:

Jonathan Pryor 2013-01-28 21:28:06 EST
Workaround: http://forums.xamarin.com/discussion/comment/3154/#Comment_3154

After this workaround default opening of axml files with Designer is gone.

I have found that it might not be XSD problem and locations of schemas, but
rather VS API for loading file.

After accidentally introducing error in axml I have double-clicked on error in
Error window. Axml opened in XML source editor, but w/o intellisense,
subsequent double-click opened file in xml source editor but WITH intellisense.

Screencast: http://www.youtube.com/watch?v=mfpedsnjusA
Comment 6 Jonathan Pryor 2013-05-22 14:35:25 UTC
*** Bug 7239 has been marked as a duplicate of this bug. ***
Comment 7 Jonathan Pryor 2013-05-23 15:31:12 UTC
Syntax highlighting is there, this is only about intellisense getting confused.
Comment 8 Jonathan Pryor 2013-06-28 14:09:45 UTC
I believe that this was fixed in 4.7.10.
Comment 9 Prashant manu 2013-07-08 10:30:27 UTC
Today we have checked this issue with following builds:

VS 2012/2010
Xamarin.Android 4.7.11028

We observed that when we open .axml file using double clicking on .axml and then click on Source tab and then search text using Ctrl+F then it does not search the specified text in .axml file and showing popup like 'File is already open. This is screencast for the same: http://screencast.com/t/rFKiyzH4eO

Hence reopening this issue.
Comment 10 Saurabh 2013-07-08 15:29:51 UTC
Today we have checked this issue on following builds :

VS 2012
X.Android 4.7.110028

Now we are able to see text color and intellisence in axml file when we use "ctrl + F" key and search some text.

Screencast :http://screencast.com/t/7kNQDgVq9sP

Hence closing this issue. Changing its status to verified.
Comment 11 PJ 2013-07-08 15:44:49 UTC
Prashant, Saurabh: Allie is describing two different methods of opening the file. In one case it works, in the other case it didn't work.

You are both saying you tried the case *that always worked*, so you can't verify with those steps.

Test case:

1. Create a new Android project
2. Open the .axml file by double clicking on it, then switching to the Source view
3. Begin typing / editing the source of the axml file.

Expected behavior:

You should get autocomplete and text coloring (the most basic intellisense) when, for instance, deleting and re-writing a line

In the universal monodroid add-in suite: https://testrail.xamarin.com/index.php?/cases/view/58329
Comment 12 Akhilesh kumar 2013-07-15 14:06:16 UTC
Today we have checked this issue with the following builds:

VS 2010/2012
MFA 4.8.00004

Now Intellisense and text coloring is displayed in the axml file whether user search .axml file with ctrl+F
or user open's .axml file by just double clicking on it.

Below is the screencast for the same:

Hence changing this issue status as a verified.
Comment 13 Carlos 2013-09-04 15:23:44 UTC
I'm using Windows 8 and VS 2012. Intellisense is not working when I click the source tab in android designer. If a select open with->automatic editor selector (xml) it works.

This behavior happens in xamarin studio and visual studio.
Comment 15 softlion 2013-12-30 04:21:49 UTC
I'm using Windows 7 and VS2012.

CTRL+F does not search the axml file.
There is no intellisense.

Xamarin.Android 4.10.01073

Hence reopening the issue.
Comment 16 Jose Miguel Torres 2014-07-17 07:12:08 UTC
tested on VSX 3.1.224 (july) and I am able to use both axml intellisense and Ctrl+F option within editor. Closing bug...
Comment 17 softlion 2014-07-17 07:17:11 UTC
I still have this bug with (VS2013 / Windows7)

CTRL-F still opens the floating "find and replace" box, which does not search the current .axml file.

And intellisense still does not work.