Bug 969 - Unspecified error occurred while create a package.
Summary: Unspecified error occurred while create a package.
Status: RESOLVED DUPLICATE of bug 1476
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 2.8 Beta 2
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Alan McGovern
Depends on:
Reported: 2011-09-21 12:49 UTC by Atin
Modified: 2012-03-08 10:33 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Image for the bug (190.68 KB, image/jpeg)
2011-09-21 12:49 UTC, Atin

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Atin 2011-09-21 12:49:09 UTC
Created attachment 457 [details]
Image for the bug

Steps to Reproduce:
1. Launch the MonoDevelop.
2. Create a solution of MonoTouch Single View application.
3. Double click on .xib file and add few buttons and label.
4. Add outlets and Actions.
5. Modify AppDelegate.cs file accordingly.
6.  Now build and run the application.
7. Right click on solution name select Tools>>Create Package.
8. Select Tarball and click on Forward button.
9. Click on Forward button.
10. Click on Create button.
11. See unspecified error message on MonoDevelop console. 

Actual result:
Unspecified error occurred when user tried to create a package of solution. Solution is running successfully on the simulator. Refer the attached screenshot.

Expected result:
Unspecified error should not be occurred when user tried to create a package of solution.

Environment Details: 
VM: Parallel Desktop 
OS:  Lion 10.7 (Guest Operating System)
MonoTouch 4.9
MonoDevelop 2.8 
Mono Framework for MAC OS X Intel Runtime
Comment 1 Marek Safar 2011-11-15 15:28:28 UTC
This command is not supposed to work for iPhone projects
Comment 2 Alan McGovern 2011-12-08 20:43:37 UTC

*** This bug has been marked as a duplicate of bug 1476 ***
Comment 3 Atin 2011-12-30 08:44:21 UTC
We have verified this issue and noticed that same error is occurring for Android applications. Please see below error message:

Solution could not be deployed: .An unspecified error occurred while running 'autogen.sh'.


Mono Develop 2.8.5 Stable
Mono Touch 5.0.4 Stable
Mono framework 2.10.7 beta
XCode 4.2 with iOS 5
Comment 4 Alan McGovern 2012-03-08 10:33:30 UTC
This is still a duplicate, please do not reopen this. If you have further information or comments it should be added to bug #1476

*** This bug has been marked as a duplicate of bug 1476 ***