Bug 9576 - Workaround to unescaping "/" (%2F)
Summary: Workaround to unescaping "/" (%2F)
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: 2.10.x
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2013-01-15 14:02 UTC by peleyal
Modified: 2015-08-29 06:50 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description peleyal 2013-01-15 14:02:56 UTC
There is a workaround for the problem on Microsoft .NET framework:

I tried to figure out if there is a similar workaround to System.Uri on the mono framework as well?

Comment 1 marcos.henrich 2015-08-29 06:50:48 UTC
The current released version of Mono (4.0) already processes Uri as .NET.

This issue and others were solved by https://github.com/mono/mono/pull/1168.