Bug 9548 - Debugger constantly crashes
Summary: Debugger constantly crashes
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 4.4.x
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2013-01-14 09:34 UTC by jonathan_chapman
Modified: 2014-01-13 10:13 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description jonathan_chapman 2013-01-14 09:34:03 UTC
When debugging our very large application it appears if we do a lot of work in a thread the application will crash with Use Fast Deployment is enabled.  Without debugging the application works no problem.  In 4.2.7 we did not have this problem.  It only occurred once we upgrade to 4.4.54.  Below is the Android log.  

01-14 08:55:48.279 I/ActivityManager(28606): START {act=android.intent.action.MAIN cat=[android.intent.category.HOME] flg=0x10000000 cmp=com.android.launcher/com.android.launcher2.Launcher u=0} from pid 32498
01-14 08:55:48.380 D/dalvikvm(28606): GC_FOR_ALLOC freed 1996K, 21% free 19486K/24647K, paused 55ms, total 66ms
01-14 08:55:48.388 I/AndroidRuntime(32498): VM exiting with result code -1, cleanup skipped.
01-14 08:55:48.411 I/WindowState(28606): WIN DEATH: Window{41e4f958 com.apexsi.apexware/com.apexsi.apexware.MainActivity paused=true}
01-14 08:55:48.419 I/ActivityManager(28606): Process com.apexsi.apexware (pid 32498) has died.
01-14 08:55:48.419 W/ActivityManager(28606): Force removing ActivityRecord{41adefa0 com.apexsi.apexware/.MainActivity}: app died, no saved state
01-14 08:55:48.451 D/Zygote  (28478): Process 32498 exited cleanly (255)
01-14 08:55:48.521 W/InputMethodManagerService(28606): Got RemoteException sending setActive(false) notification to pid 32498 uid 10033
01-14 08:55:59.997 D/AndroidRuntime(32620): Shutting down VM

I've tried this on 3 different devices with no luck and my colleagues have the same issue.

This is with Visual Studio 2010. Target API 14

The project has Linking - Sdk and User Assemblies, Use Shared Runtime, and Use Fast Deployment.

Unfortunately I cannot provide the source code for IP reasons.
Comment 1 jonathan_chapman 2013-01-15 11:28:05 UTC
I test with Use Fast Deployment off and the first time it worked but ever since it hasn't worked.  

This is needed ASAP because we can no longer debug our project so it is costing significant time to resolve any bug.
Comment 2 Jonathan Pryor 2014-01-13 09:33:11 UTC
Does this still happen with Xamarin.Android 4.10?

What Android device are you running this on? Is it possible to run it on a Jelly Bean or later device (Android v4.1 or later)?
Comment 3 jonathan_chapman 2014-01-13 10:13:41 UTC
Yes this has been fixed in a more recent release.