Bug 9523 - Intermittently cannot deploy to device from MD debugger: Device is invalid
Summary: Intermittently cannot deploy to device from MD debugger: Device is invalid
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 6.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2013-01-13 17:33 UTC by Terry Westley
Modified: 2013-12-05 18:34 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Terry Westley 2013-01-13 17:33:45 UTC
I intermittently cannot deploy to device from MD debugger. (No, device is not locked.)

Device is iPhone 3GS, iOS 6.0.1, 16GB, plenty of memory available; see MD version info at bottom of this report.

Of several things I've tried, the only thing that appears to fix it is terminating app with app switcher, quitting MD and then running mtouch from terminal command line with command in Deploy to Device log below. The mtouch command successfully installs the app, then MD starts to work as expected to deploy to device from debugger. (I don't know which action actually fixes the problem.)

I'm filing this report because it has happened twice now and the Deploy to Device log says "Please file a bug report."

---------------------- Deploy to Device log ----------------------------------------
/Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" -installdev "/Users/twestley/Dev/iPhone/MT/PythonMath/PythonMath/bin/iPhone/Debug/PythonMath.app"
Please ensure your device is connected...
Connected to: iPhone 3GS iOS 6
Initializing file service...
Transferring application
Finalizing file service...
error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
MonoTouch.MobileDevice.MobileDeviceException: Device is invalid (0xe8000084)
at MonoTouch.Installation.Device.Connect () <0x0007b>
at MonoTouch.Installation.Installer/<ExecuteWithSession>c__AnonStorey4.<>m__3 (object,System.EventArgs) <0x00017>
at MonoTouch.Installation.Device.NotificationCallback (MonoTouch.MobileDevice.am_device_notification_callback_info&) <0x00075>
at (wrapper native-to-managed) MonoTouch.Installation.Device.NotificationCallback (MonoTouch.MobileDevice.am_device_notification_callback_info&) <0x0003f>
at (wrapper managed-to-native) MonoTouch.CoreFoundation.CFRunLoop.CFRunLoopRun () <0x00003>
at MonoTouch.CoreFoundation.CFRunLoop.Run () <0x0000b>
at MonoTouch.Installation.Installer.ExecuteWithSession (string,MonoTouch.Installation.Installer/Executor) <0x000d7>
at MonoTouch.Installation.Installer.InstallApplication (string,string) <0x000b3>
at MTouch.Main2 (string[]) <0x043c3>
at MTouch.Main (string[]) <0x00017>

The application was terminated by a signal: SIGHUP

----------------------- MD version info -----------------------------

MonoDevelop 3.0.6
Installation UUID: 05975674-97f1-4dbf-8c1d-194cb7d4b9ff
	Mono 2.10.9 (tarball)
	GTK 2.24.10
	GTK# (
	Package version: 210090011
Mono for Android: Not Installed

Apple Developer Tools:
	 Xcode 4.5.1 (1842)
	 Build 4G1004
Monotouch: 6.0.8
Build information:
	Release ID: 30006000
	Git revision: 90a53d1938aa812828adda89fb92d27a716c1218
	Build date: 2012-11-28 16:52:33+0000
	Xamarin addins: cc24f8812681fe7bb1b25780dc04d93dca0ecc03
Operating System:
	Mac OS X 10.7.5
	Darwin macbook13.home 11.4.2 Darwin Kernel Version 11.4.2
	    Thu Aug 23 16:26:45 PDT 2012
	    root:xnu-1699.32.7~1/RELEASE_I386 i386
Comment 1 Terry Westley 2013-01-13 22:32:40 UTC
Workaround clarified: Simply terminating app with app switcher (task manager) makes the problem go away.
Comment 2 Terry Westley 2013-01-20 21:13:57 UTC
Workaround false alarm. Nothing I have tried consistently fixes the problem.

Sorry I missed this: possible duplicate with #7728.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2013-01-21 05:35:00 UTC
Have you tried rebooting the device?

Also check the device log (MonoDevelop's menu -> View -> Pads -> iOS Device Log) for any messages when you try to deploy.
Comment 4 PJ 2013-11-19 17:04:44 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 5 PJ 2013-12-05 18:34:54 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.