Bug 9483 - app crashed on iOS 5
Summary: app crashed on iOS 5
Status: RESOLVED DUPLICATE of bug 9261
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: 6.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2013-01-10 22:25 UTC by Art
Modified: 2013-01-14 06:48 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

crash report and version info (26.96 KB, text/plain)
2013-01-10 22:25 UTC, Art
crash report 2 (26.34 KB, text/plain)
2013-01-11 12:15 UTC, Art
I created a test app (683.24 KB, application/zip)
2013-01-11 23:19 UTC, Art

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Art 2013-01-10 22:25:40 UTC
Created attachment 3197 [details]
crash report and version info

I recompiled with 6.08 Monotouch and the app crashes when I run on iOS 5. It works fine on iOS 6. I haven't changed anything and it worked fine, when I compiled with previous version.

Please see the attached file for version info and crash report
Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-01-11 06:48:26 UTC
The crash report hasn't been symbolicated properly, all the relevant frames in BEWriteHD doesn't show up correctly - could you make sure it is? It's usually enough to just view the crash report in Xcode (it might take a few seconds though for Xcode to finish symbolicating it).
Comment 2 Art 2013-01-11 12:15:49 UTC
Created attachment 3201 [details]
crash report  2
Comment 3 Art 2013-01-11 12:21:16 UTC
I attached a new crash report file but I am not sure that is what you want. I click re symbolicate.
Comment 4 Rolf Bjarne Kvinge [MSFT] 2013-01-11 19:15:28 UTC
The crash report is still not symbolicated properly, the problem is the lines like these:

6   BEWriteHD                     	0x00b31620 0x1000 + 11732512

Try the following:

1) Clean and rebuild your project.
2) Install on your device & make it crash.
3) Open the crash report in Xcode.

It's important that you do not rebuild your project between 2) and 3).
Comment 5 Art 2013-01-11 20:11:13 UTC
That is what I did. All the nib files and code are in a different dll. Do you think that might be the reason?
Comment 6 Rolf Bjarne Kvinge [MSFT] 2013-01-11 20:13:38 UTC
No, that's not the problem.

Can you try executing this from a terminal, and attach the output:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/Library/PrivateFrameworks/DTDeviceKit.framework/Versions/A/Resources/symbolicatecrash -v /path/to/crash-report.crash

(that's all in one line, and remember to fix the path to the crash report)
Comment 8 Art 2013-01-11 23:19:10 UTC
Created attachment 3204 [details]
I created a test app

I created a test app.
Looks like UIWebView causing the issue
Comment 9 Rolf Bjarne Kvinge [MSFT] 2013-01-14 06:48:39 UTC
This has already been fixed (but not released). See the other bug report for more details.

*** This bug has been marked as a duplicate of bug 9261 ***