Bug 9467 - [MTVS]: Error "Another instance is running" returned while trying to connect on remote server from connection wizard
Summary: [MTVS]: Error "Another instance is running" returned while trying to connect ...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 0.x Insider Preview
Hardware: PC Mac OS
: High normal
Target Milestone: 1.2.x
Assignee: Vinicius Jarina
Depends on:
Reported: 2013-01-10 17:30 UTC by GouriKumari
Modified: 2015-01-05 11:21 UTC (History)
9 users (show)

Is this bug a regression?: ---
Last known good build:

mtbserver.log (2.03 MB, application/octet-stream)
2013-01-10 17:30 UTC, GouriKumari

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Comment 3 John Hair 2013-02-23 09:27:09 UTC
I sometimes get the same error when compiling in Visual Studio 2012 on Windows 8 in Parallels, connection to Xamarin.iOS on the Mac. It appears to happen after a problem has occurred with the build, like I have tried to build too soon and the mac build app detects a new connection and thinks its another VS instance, which its not.
Comment 4 Vinicius Jarina 2013-05-27 15:56:00 UTC
Can you create a screencast step-by-step how to repro this issue?

Thank you.
Comment 5 John Hair 2013-05-27 16:01:23 UTC
Hi Vinicius (is that your first name? Apologies if I have got this wrong)
I believe this issue was due to my incorrect Mac name issue you helped resolve for me previously. I haven't had this issue since, so please feel free to close this bug as an issue with Mac network configuration as the cause.

Comment 6 Dominique Louis 2013-06-04 11:17:12 UTC
Please retest with latest 1.2.x Release.
Comment 7 narayanp 2013-06-19 08:26:49 UTC
Today we have checked this issue with following builds:

All WIndows
VS 2012/2010
MTVS 1.2.121

and have followed the same steps as mentioned in this bug like:
1. Configure Mac build host
2. Delete Mac build host keys
3. Reestablish connection with same build host.

and we are not getting any error we are successfully able to connect to build host.

Also we have checked this when we open iOS project, Configure build host, close VS and reopen same project again in same Instance of VS.

Changing the status to Verified