Bug 8309 - Wrong dll mapping for libgdiplus under Windows
Summary: Wrong dll mapping for libgdiplus under Windows
Alias: None
Product: Class Libraries
Classification: Mono
Component: libgdiplus ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
: 14586 ()
Depends on:
Reported: 2012-11-09 06:39 UTC by Thomas Klose
Modified: 2015-12-29 09:25 UTC (History)
10 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Thomas Klose 2012-11-09 06:39:44 UTC
Mono version 3.0.1 Alpha for Windows:

The file "etc\mono\config" in installation directory contains a wrong dll mapping:

	<dllmap dll="ggdiplus" target="/tmp/install/lib/libgdiplus.so" />
	<dllmap dll="ggdiplus.dll" target="/tmp/install/lib/libgdiplus.so" />

This results in a DllNotFoundException while starting applications which utilize System.Drawing.

For Windows, this problem can be solved by removing the entries from config file.
Comment 1 David Karlaš 2013-05-29 01:15:25 UTC
It seems to be that this two lines https://github.com/mono/mono/commit/aa3461352194e32b97b6f9a618cd5a10d3940fea should have additional attribute  os="!windows" but im not 100% otherwise i would make pull request.
Comment 2 Martín Coll 2013-06-14 10:58:51 UTC
Removing those two lines from config made my application start flawlessly.

Comment 3 Rogier Hofboer 2013-09-13 08:30:55 UTC
*** Bug 14586 has been marked as a duplicate of this bug. ***
Comment 4 BurnSpamAddress 2014-01-07 16:55:47 UTC
Any chance of getting a fix for this? These two lines are invalid on any operating system, not just Windows.
Comment 5 leezer3 2014-01-25 10:00:21 UTC
Still an issue, I've just spent quite a while figuring out why the heck something worked on Linux, but not on Windows.....
Comment 6 Baltasar 2014-04-09 15:32:14 UTC
Same here. I've been struggling to find out why my WinForms application was suddenly not working on Windows, and found this:


...which is misleading, since it does not apply to Windows.

This invalidates the use of mono > 3.0 for any user trying to execute WinForms (you can't say to a client "open an administratior cmd and go to programs\mono\etc\config...").

Also, the bug was found in 11/2012 (mono 3.0.1),
and bug 14586, a duplicate of this bug, was (re-)found in 09/2013.
Currently, in 4/2014 (mono-3.2.3), the bug has not still been solved, while
the fix seems just to add an os="!windows" attribute to those lines.

The fix seems to be straightforward, so, why has it not been solved yet?
Comment 7 Baltasar 2014-04-10 09:36:12 UTC
I don't understand, it seems that this bug is already fixed:


what's going on?
Comment 8 Andres G. Aragoneses 2014-04-10 11:55:20 UTC
> what's going on?

Look at the fix:


As you can see there, in the tag list, tt went to mono 3.4.0 (not 3.2.8).
Comment 9 Matthias Mailänder 2015-12-29 09:25:11 UTC
Can you build a Windows version of http://download.mono-project.com/archive/3.4.0/ then please so we have a version of Mono that actually runs and works on Windows XP?