Bug 8210 - Problem to connect debugger after upgrade to iOS 6.1
Summary: Problem to connect debugger after upgrade to iOS 6.1
Status: RESOLVED DUPLICATE of bug 8166
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 6.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Rolf Bjarne Kvinge [MSFT]
Depends on:
Reported: 2012-11-04 14:38 UTC by bard.mannseth
Modified: 2012-11-05 05:25 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description bard.mannseth 2012-11-04 14:38:33 UTC
Everything worked ok on iOS 6.0. After upgrading to iOS 6.1 I get this one when trying to deploy and debug my app to my iPhone 4s:

Please ensure your device is connected...
Connected to: BM's iPhone 4s
error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
System.Exception: Could not find developer tools for this device. Please connect this device to Xcode to install the development support files.
  at MonoTouch.Installation.Device.MountDeveloperImage () [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer.KillApplication (MonoTouch.Installation.Device d, System.String appId) [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer+<KillApplication>c__AnonStorey7.<>m__8 (MonoTouch.Installation.Device d) [0x00000] in <filename unknown>:0 
Loaded assembly: /private/var/mobile/Applications/6B9E5482-FB66-4D9C-ADAF-27DB6FB1E68D/WatchAccuracy.app/System.Core.dll [External]
Loaded assembly: /private/var/mobile/Applications/6B9E5482-FB66-4D9C-ADAF-27DB6FB1E68D/WatchAccuracy.app/monotouch.dll [External]
Loaded assembly: /private/var/mobile/Applications/6B9E5482-FB66-4D9C-ADAF-27DB6FB1E68D/WatchAccuracy.app/System.dll [External]
Comment 1 bard.mannseth 2012-11-04 15:16:54 UTC
I have of course tried to open Xcode and connect the iPhone, but it didn´t do any good ,-)
Comment 2 Jeffrey Stedfast 2012-11-04 17:57:35 UTC
I think this is the bug that the MonoTouch developers fixed as part of the MonoTouch 6.0.6 beta

Try installing that and seeing if that fixes it for you.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2012-11-05 05:25:38 UTC
See bug #8166 for a workaround or use the 6.0.6 beta release.

*** This bug has been marked as a duplicate of bug 8166 ***