Bug 8051 - SectionIndexTitles doesn't work on device
Summary: SectionIndexTitles doesn't work on device
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: 6.0.x
Hardware: Other All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2012-10-29 18:36 UTC by Dean Cleaver
Modified: 2012-11-01 15:32 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Device (50.14 KB, image/png)
2012-10-29 18:36 UTC, Dean Cleaver
Simulator (28.04 KB, image/png)
2012-10-29 18:37 UTC, Dean Cleaver

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Dean Cleaver 2012-10-29 18:36:37 UTC
I have a few views with Section Index Titles, and with SDK 6 they don't work on the device - but they do work in the simulator. This code has been working for years, but stopped recently. I've tried both debug and release build, but no luck - is this a bug or has something changed? I suspect a bug, as it still works in the simulator.
Comment 1 Dean Cleaver 2012-10-29 18:36:52 UTC
Created attachment 2811 [details]
Comment 2 Dean Cleaver 2012-10-29 18:37:08 UTC
Created attachment 2812 [details]
Comment 3 Rolf Bjarne Kvinge [MSFT] 2012-10-30 12:51:12 UTC
Can you try adding --noregistrar to the additional mtouch arguments (for the device build) and see if that changes anything?
Comment 4 Dean Cleaver 2012-10-30 13:03:56 UTC
No difference.
Comment 5 Rolf Bjarne Kvinge [MSFT] 2012-10-30 18:39:56 UTC
I tried the Table and Cell Styles sample [1] and it shows the section index titles just fine, so there must be something else going on (which means we'll need a test case to figure it out).

[1] https://github.com/xamarin/monotouch-samples/tree/master/TableAndCellStyles - just tap on the Indexed Grouped or Indexed Plain entires in the first view.
Comment 6 Dean Cleaver 2012-11-01 15:32:14 UTC
Found the problem - this fix for a previous known bug now causes it to fail on the device and must be removed.

Comment 7 Dean Cleaver 2012-11-01 15:32:37 UTC
Can be closed