Bug 8003 - Unexpected Error
Summary: Unexpected Error
Status: RESOLVED DUPLICATE of bug 7728
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 6.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2012-10-25 16:21 UTC by David
Modified: 2013-01-10 18:24 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description David 2012-10-25 16:21:59 UTC
Please ensure your device is connected...
Connected to: iPhone 5
error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
MonoTouch.MobileDevice.MobileDeviceException: Send Message Error (error: 0xe800002d)
  at MonoTouch.Installation.Device.SecureStartService (MonoTouch.CoreFoundation.CFString service) [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.InstallationProxyService..ctor (MonoTouch.Installation.Device d) [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer.KillApplication (MonoTouch.Installation.Device d, System.String appId) [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer+<KillApplication>c__AnonStorey7.<>m__8 (MonoTouch.Installation.Device d) [0x00000] in <filename unknown>:0
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-10-25 17:27:01 UTC
Is this a reproducible error or is it a one-time thing?

Could you get the device console output from Xcode's Organizer if it's reproducible?
Comment 2 Sebastien Pouliot 2012-10-26 09:58:55 UTC
same stack trace as #7728

When it occurred to me I could reproduce it several times. I noticed that the deployment times were very long (and the Mac-side did not look to be working very hard). Rebooting the device fixed this. I have not been able to reproduce this again afterward.

Does this situation sounds like what you're experiencing ? 

you can answer this, and Rolf's earlier question, on the previous bug report. Thanks!

*** This bug has been marked as a duplicate of bug 7728 ***
Comment 3 David 2012-10-26 11:52:55 UTC
I have not been able to reproduce this issue.  It only occurred once for me.  I have not rebooted my Mac or my device.  

To be honest the only reason I filed the bug is because MonoDevelop asked me to in the output window.  :)
Comment 4 Tim Dawson 2013-01-10 16:36:00 UTC
This exact thing happened to me today. Very slow deployment times, then the error above. Rebooting the iPad was what fixed it.
Comment 5 Rolf Bjarne Kvinge [MSFT] 2013-01-10 18:24:31 UTC
I had this happening the other day too, where the deployment times suddenly became very slow. But it was slow in Xcode and iTunes too, so I don't think it was a MonoTouch problem (and restarting the device fixed it, and it hasn't happened again).