Bug 7950 - Osmdroid binding fails to generate in 4.2.8 Beta. Regression from 4.2.7
Summary: Osmdroid binding fails to generate in 4.2.8 Beta. Regression from 4.2.7
Alias: None
Product: Android
Classification: Xamarin
Component: Bindings ()
Version: 4.2.x
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Atsushi Eno
Depends on:
Reported: 2012-10-23 13:43 UTC by Jeremy Kolb
Modified: 2012-11-02 11:49 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

OSMDroid project (1.08 MB, application/zip)
2012-10-23 15:52 UTC, Jeremy Kolb

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jeremy Kolb 2012-10-23 13:43:28 UTC
Try to generate the bindings for OsmDroid from the example on the website.  The bindings will generate but will fail to include some classes that were included when build with MfA 4.2.7 such as ResourceProxy.

See http://lists.ximian.com/pipermail/monodroid/2012-October/012692.html
Comment 2 Jeremy Kolb 2012-10-23 15:52:22 UTC
Created attachment 2781 [details]
OSMDroid project

Attached is my project.  It's based off of the one from the website but includes a few more fixes + javadoc integration.
Comment 3 Jeremy Kolb 2012-10-23 15:53:29 UTC
See attachment 2781 [details] above for the one that I'm building.  It should be about the same as the one directly from the website but it has a few changes.  Apples to apples and all that.
Comment 4 Atsushi Eno 2012-10-24 05:31:28 UTC
It seems our monodroid-samples has different project than my experiment stuff... This is Metadata.xml that I used for it and never invalidates IResourceProxy:

  <attr path="/api/package[@name='org.osmdroid.tileprovider.modules']/class[@name='MapTileModuleProviderBase.TileLoader']" name="visibility">public</attr>
  <attr path="/api/package[@name='org.osmdroid.tileprovider']/class[@name='MapTileProviderBase.ZoomInTileLooper']/method[@name='handleTile']" name="visibility">protected</attr>
  <attr path="/api/package[@name='org.osmdroid.tileprovider.modules']/class[@name='MapTileDownloader.TileLoader']/method[@name='loadTile']" name="visibility">protected</attr>
  <attr path="/api/package[@name='org.osmdroid.tileprovider.modules']/class[@name='MapTileFileArchiveProvider.TileLoader']/method[@name='loadTile']" name="visibility">protected</attr>
  <attr path="/api/package[@name='org.osmdroid.tileprovider.modules']/class[@name='MapTileFilesystemProvider.TileLoader']/method[@name='loadTile']" name="visibility">protected</attr>
  <attr path="/api/package[@name='org.osmdroid.views.overlay']/class[@name='DirectedLocationOverlay']/method[@name='draw']" name="visibility">protected</attr>
  <attr path="/api/package[@name='org.osmdroid.views.overlay']/class[@name='ItemizedOverlay']/method[@name='draw']" name="visibility">protected</attr>
  <attr path="/api/package[@name='org.osmdroid.views.overlay']/class[@name='MyLocationOverlay']/method[@name='draw']" name="visibility">protected</attr>
  <attr path="/api/package[@name='org.osmdroid.views.overlay']/class[@name='SimpleLocationOverlay']/method[@name='draw']" name="visibility">protected</attr>
  <attr path="/api/package[@name='org.osmdroid.views.overlay']/class[@name='ScaleBarOverlay']/method[@name='draw']" name="visibility">protected</attr>
  <attr path="/api/package[@name='org.osmdroid.tileprovider.modules']/class[@name='MapTileDownloader']/method[@name='setTileSource']" name="visibility">protected</attr>
Comment 5 Atsushi Eno 2012-10-24 06:58:23 UTC
Actually I cannot reproduce this with 4.2.8. It builds either on VS2010 or MonoDevelop. And our monodroid-samples/OsmDroidBindinds builds too.
Comment 6 Jeremy Kolb 2012-10-24 09:08:28 UTC
Hm that's odd.  I'm using VS 2012 but I can't imagine that would make a difference.
Comment 7 Jeremy Kolb 2012-10-24 10:25:33 UTC
Ok I reinstalled the 4.2.8 beta that was released yesterday and downloaded monodroid-samples/OsmDroidBingings. It generated IResourceProxy for me.

I then tried with the zip file that I uploaded and it did not.  I thought maybe the Javadoc reference might be the problem so I took that out but it didn't help.  I also tried your xml file and it failed to compile for me in both projects.  Did you test with the recently released beta?
Comment 8 Atsushi Eno 2012-10-24 15:01:51 UTC
Hmm... that's weird. Yes, the version I tried was the 4.2.8 beta from this week. I'll try VS2012 later and post another comment if it gives different result from VS2010.

For reference, my metadata.xml on comment #4 does not help compiling the binding *successfully*. It's just to generate IResourceProxy.
Comment 9 Jeremy Kolb 2012-10-24 16:59:36 UTC
I tried it on both 2010 and 2012 and it failed both times with that project.
Comment 10 Atsushi Eno 2012-10-30 08:04:19 UTC
I couldn't reproduce this even with 4.2.8. Anyone else reproduced the issue?
Comment 11 Atsushi Eno 2012-10-30 08:04:39 UTC
I mean, with VS2012.
Comment 13 Jeremy Kolb 2012-10-30 10:12:17 UTC
I've just uploaded a (hopefully) private attachment that contains the project that I am working on that should demonstrate the problem.
Comment 14 Atsushi Eno 2012-10-31 03:24:34 UTC
Ok after investigating why things differentiated between OsmDroidBindingExample and yours, now I could reproduce the issue with monodroid-samples ones too. It didn't fail only because it had wrong assembly reference to OsmDroid.dll while it should have been to *project* reference. Now I got a reproducible case I can investigate.
Comment 18 Atsushi Eno 2012-11-02 11:49:52 UTC
Ok, thanks for the testing, now I close this specific bug.