Bug 7823 - Code action "Extract field" on parameters needs better name
Summary: Code action "Extract field" on parameters needs better name
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: 4.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
Depends on:
Reported: 2012-10-12 19:07 UTC by Mikayla Hutchinson [MSFT]
Modified: 2012-10-25 05:48 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Mikayla Hutchinson [MSFT] 2012-10-12 19:07:42 UTC
The code action "Extract field" on parameters needs better name, maybe "Assign to new field"?

The name "Extract field" sounds like it would create a field, but remove the parameter and make every callsite assign to the field (though that wouldn't be very useful).
Comment 1 Mike Krüger 2012-10-25 05:48:11 UTC
Yes extract field is a very strange name for this action. (no this time I didn't do it :))