Bug 7709 - Code formatter adds extra space in "event"
Summary: Code formatter adds extra space in "event"
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: Trunk
Hardware: PC Linux
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
Depends on:
Reported: 2012-10-07 10:48 UTC by Peter Hultqvist
Modified: 2012-10-08 04:39 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Peter Hultqvist 2012-10-07 10:48:55 UTC
Using the following code:

public event Action Push = delegate {};

The Format document turn it into this, not the space in "event"

public e vent Action Push = delegate


I noted however that if I use double semicolon in the end the line is preserved. Those double semicolon is a result of the code completion writing the delegate, it would seem that it is a bug in itself unless it's a workaround.

public event Action Push = delegate{};;
Comment 1 Mike Krüger 2012-10-08 03:16:53 UTC
Should've been fixed a while ago - which version are you using ?

(I'm using a much newer version than the current released - that's why I ask)
Comment 2 Peter Hultqvist 2012-10-08 04:39:19 UTC
I was using the public master branch:

commit 1d0d35cfd5b6bc3bb04e46c56773377ae960c121
Author: Marek Habersack <grendel@twistedcode.net>
Date:   Thu Sep 27 16:37:53 2012 -0400

I tried the latest one and the bug is there too.

commit 52a5312b16210ed4830b8d7437232c423fadbaf8
Author: Jonathan Pryor <jonpryor@vt.edu>
Date:   Fri Oct 5 16:35:48 2012 -0400

Last I tried the monodevelop-3.0-series branch but got the same result there

commit dd8226e1e8746c66c55fff3292bcca499e5f7d25
Author: Jeffrey Stedfast <fejj@gnome.org>
Date:   Wed Oct 3 10:20:41 2012 -0400