Bug 7588 - CompilationExpection for Aspose.Pdf.dll
Summary: CompilationExpection for Aspose.Pdf.dll
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Marek Safar
Depends on:
Reported: 2012-10-02 10:54 UTC by marxin.liska
Modified: 2012-10-05 07:57 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Aspose.Pdf.dll (3.84 MB, application/octet-stream)
2012-10-02 11:37 UTC, marxin.liska

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description marxin.liska 2012-10-02 10:54:19 UTC
   we are running latest mono (2.11.5) and XSP4 with MVC4 application. Application works fine but compilation exception occures for Aspose.Pdf.dll. I tried to create a simple console application that uses the same library and execution works without any problems.

Could you please help me how to display more detail informations about compilation exception?

CS0009: Metadata file `/var/www/localhost/htdocs/tc6_new/Bin/Aspose.Pdf.dll' does not contain valid metadata

Description: Error compiling a resource required to service this request. Review your source file and modify it to fix this error.
Details: CS0009: Metadata file `/var/www/localhost/htdocs/tc6_new/Bin/Aspose.Pdf.dll' does not contain valid metadata
Error origin: Compiler
Error source file: ~/Global.asax
Exception stack trace:
  at System.Web.Compilation.AssemblyBuilder.BuildAssembly (System.Web.VirtualPath virtualPath, System.CodeDom.Compiler.CompilerParameters options) [0x00000] in <filename unknown>:0 
  at System.Web.Compilation.AssemblyBuilder.BuildAssembly (System.Web.VirtualPath virtualPath) [0x00000] in <filename unknown>:0 
  at System.Web.Compilation.BuildManager.GenerateAssembly (System.Web.Compilation.AssemblyBuilder abuilder, System.Web.Compilation.BuildProviderGroup group, System.Web.VirtualPath vp, Boolean debug) [0x00000] in <filename unknown>:0 
  at System.Web.Compilation.BuildManager.BuildInner (System.Web.VirtualPath vp, Boolean debug) [0x00000] in <filename unknown>:0 

Version Information: 2.11.5 (master/77ac49c Sat Sep 29 22:30:26 CEST 2012); ASP.NET Version: 4.0.30319.17020
Comment 1 Marek Safar 2012-10-02 11:24:53 UTC
What is Aspose.Pdf.dll, could you add it as an attachment.
Comment 2 marxin.liska 2012-10-02 11:37:13 UTC
Created attachment 2670 [details]
Comment 3 marxin.liska 2012-10-02 11:38:06 UTC
Aspose.Pdf.dll is a general PDF manipulation library.
Website: www.aspose.com
Comment 4 Marek Safar 2012-10-04 07:58:53 UTC
Fixed in master.
Comment 5 marxin.liska 2012-10-05 06:02:33 UTC
I tried to rebuild mono but still having the same issue.

Version Information: 2.11.5 (master/9a2345d Fri Oct 5 10:13:46 CEST 2012); ASP.NET Version: 4.0.30319.17020
Comment 6 Marek Safar 2012-10-05 06:07:36 UTC
The error message is gone so it should not report exactly same error message. Your probably didn't install updated mcs correctly.
Comment 7 marxin.liska 2012-10-05 07:57:11 UTC
You was right, I forgot to use a new mcs compiler ;)
Thanks for fixing.