Bug 7384 - OpenTK-1.0 between Mono.Touch Mono.Android incompatible
Summary: OpenTK-1.0 between Mono.Touch Mono.Android incompatible
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries ()
Version: 4.2.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: 4.14.0
Assignee: Bugzilla
Depends on:
Reported: 2012-09-21 10:43 UTC by SE
Modified: 2014-07-04 07:56 UTC (History)
11 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description SE 2012-09-21 10:43:20 UTC
I was trying to reuse the drawing code between an IOS and Android app, but using the openTK-1.0 library as recommended in both project with OpenGLES20 shows a lot of differences in the method/function signatures, enums etc. therefore i was unable to ruse openGL2.0 code. Why are the signatures different?
Comment 1 Steve Williams 2013-02-05 11:11:27 UTC
I've come across this as well now.  One example:

On iOS
  GL.GetUniformLocation(int, string);
  GL.GetUniformLocation(uint, string);

On Android
  GL.GetUniformLocation(int, StringBuilder);
  GL.GetUniformLocation(uint, StringBuilder);

Comment 2 Rainer Mager 2014-04-28 01:17:16 UTC
Any progress on this bug? Without consistency between iOS and Android the benefit of Xamarin is significantly reduced.
Comment 3 Radek Doulik 2014-04-28 10:38:58 UTC
This is already fixed, I think it will be part of Xamarin.Android 4.14.x release. Not sure which version of Xamarin.iOS will have it, but probably around the same time as Xamarin.Android release.
Comment 4 renan jegouzo 2014-05-27 10:16:29 UTC
yep, same waiting this fix since few years now, to remove all the conditional code in my android/ios projects
Comment 5 renan jegouzo 2014-05-27 10:18:29 UTC
you can use opentk 1.0 on ios and openTk (not 1.0) on android they are more similar.
Comment 6 Prashant manu 2014-06-03 03:09:05 UTC
We have checked opentk1.0 in iOS and it is showing 
  GL.GetUniformLocation(int, string);
  GL.GetUniformLocation(uint, string);

but for android we are not seeing opentk1.0 Library to compare the similarity.
Screencast for this: http://www.screencast.com/t/2Fr4NtbPJdJD

Please let us know if fix is implemented or not.

Environment Info:
Xamarin Studio Version 5.1 (build 322)
Git revision: e79f17166d197fa4e7b2750c623d3eed3209aa98
Xamarin addins: b68a34ef2fc4c46b045dc38e26fb199bfe1b201d
Xamarin.iOS Version: Hash: a82e30c
Comment 7 Radek Doulik 2014-06-03 13:51:08 UTC
This is fixed and will be available in he next release. (Mono.Android 4.14.x)
Comment 8 narayanp 2014-06-05 08:45:13 UTC
I have checked this issue with latest X.Android 4.14.0-13 an I am still not seeing OpenTK and OpenTK-1.0 assemblies for android. This is the screencast for the same: http://www.screencast.com/t/3G9cHSlzfG

=== Xamarin Studio ===

Version 5.1 (build 386)
Installation UUID: 2591d519-875d-4afe-a3d9-5fcf391bbd2d
	Mono 3.6.0 ((no/8dcee6c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 306000000

=== Apple Developer Tools ===

Xcode 4.6.3 (2068)
Build 4H1503

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: fc6f56b
Build date: 2014-05-19 19:10:29-0400

=== Xamarin.Android ===

Version: 4.14.0 (Business Edition)
Android SDK: /Users/nischal/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_35"
Java(TM) SE Runtime Environment (build 1.6.0_35-b10-428-11M3811)
Java HotSpot(TM) 64-Bit Server VM (build 20.10-b01-428, mixed mode)

=== Xamarin.Mac ===

Version: (Starter Edition)

=== Build Information ===

Release ID: 501000386
Git revision: 58b22671f2a21d76dda7adcd09c87865b5467fa0
Build date: 2014-06-05 04:43:48-04
Xamarin addins: 428ee72fa31962f6f93316e9af54e0b111cd3b3c

=== Operating System ===

Mac OS X 10.7.4
Darwin nischals-Mac-mini.local 11.4.0 Darwin Kernel Version 11.4.0
    Mon Apr  9 19:32:15 PDT 2012
    root:xnu-1699.26.8~1/RELEASE_X86_64 x86_64
Comment 9 Radek Doulik 2014-06-05 09:41:41 UTC
I think that it is not showing because current XS and VS doesn't work with latest Mono.Android. If you switch to v1.6 framework, you should be able to see OpenTK-1.0 in the references, but probably still not be able to deploy the app.

It should be fixed once IDE's are updated for Mono.Android changes.
Comment 10 Jonathan Pryor 2014-06-05 17:36:14 UTC
The problem mentioned in Comment #6 and Comment #8 is a Xamarin Studio bug and is being tracked in Bug #20402.
Comment 11 Tajinder Singh 2014-07-04 07:56:44 UTC
I have checked this issue with following builds:

X.S 5.2 (build 179)
X.Android 4.14.0-45
X.iOS 7.2.6-17

Now I am seeing 
GL.GetUniformLocation(int, string);
GL.GetUniformLocation(uint, string); for both iOS and Android. This is the screencast for the same: http://www.screencast.com/t/pMtZJh7PUgkt

Hence, closing this issue.