Bug 7306 - Quotation Marks display incorrectly
Summary: Quotation Marks display incorrectly
Status: RESOLVED DUPLICATE of bug 4205
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Michael Natterer
Depends on:
Reported: 2012-09-19 14:26 UTC by Allie Miller
Modified: 2013-11-20 14:31 UTC (History)
6 users (show)

Tags: gtk
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Allie Miller 2012-09-19 14:26:29 UTC
Case #17120

Using the keyboard on a Macbook Pro, but with the setting to Brazil.
In MonoDevelop pressing (Shift) to display the quotation marks (") occurs it appears slanted (or like the following image)-> (˝).

Attempted to use MonoDevelop, and problem still persists.

System information:
Installation UUID: d93935cd-2144-48c8-8183-2d83beb8fc11
Mono 2.10.9 (tarball)
GTK 2.24.10
GTK# (
Package version: 210090011
Mono for Android: 4.2.5 (Evaluation)
Android SDK: /Users/ruda/Library/Developer/Xamarin/android-sdk-mac_x86
Supported Android versions:
2.1 (API level 7)
2.2 (API level 8)
2.3 (API level 10)
3.1 (API level 12)
4.0 (API level 14)
Java SDK: /usr
Apple Developer Tools:
Xcode 4.4.1 (1488)
Build 4F1003
Monotouch: 5.4.1
Build information:
Release ID: 30004006
Git revision: 0cf43d761292de23383842f385fcba4645b03854
Build date: 2012-09-06 21:36:19+0000
Xamarin addins: 75a3c9ec1a014eebf0f8346280ba8d7ad9629d3d-dirty
Operating System:
Mac OS X 10.8.1
Darwin MacBook-Pro-de-Ruda.local 12.1.0 Darwin Kernel Version 12.1.0
Tue Aug 14 13:29:55 PDT 2012
root:xnu-2050.9.2~1/RELEASE_X86_64 x86_64
Comment 1 Mike Krüger 2012-09-20 01:28:40 UTC
It has to do with the keyboard input - atm I can only recommend working with the us keyboard layout.
Comment 2 Mike Krüger 2012-09-20 04:21:23 UTC
@mitch: is that fixed in our current internal gtk ?
Comment 3 Michael Natterer 2012-09-20 04:33:38 UTC
I have to check with that keyboard layout, will do.
Comment 4 Michael Natterer 2012-09-21 14:12:39 UTC
It's indeed broken, I was sure I fixed that, maybe I re-broke it
with another commit, will fix.
Comment 5 Michael Natterer 2012-10-11 05:26:26 UTC
I can't reproduce that, I can enter " on a brazilian keyboard
layout just fine. In Comment 4 I tested us-intl and there is a glitch
when using " as compose key to produce umlauts. They get composed into
glyphs with double acutes, not umlauts, but that's unrelated.
Comment 6 Ruda 2012-12-20 10:41:41 UTC
Michael Natterer,

The problem persists in the new version 3.0.5.
Make this setting:

Configuration Keyboard: U.S. International - PC

In Brazil Layout works perfectly, but the layout "U.S. International - PC"

Now have to see whether this layout because mine is Portuguese.

Comment 7 Mikayla Hutchinson [MSFT] 2012-12-20 14:02:47 UTC
Ruda, the problem is not in MonoDevelop, it is in GTK+, which is included in the Mono package. We have not yet made a new Mono release with the latest GTK+ packages.
Comment 8 Ruda 2012-12-20 14:05:37 UTC
And when will have this problem solved?
It's been over 1 year and a half that this problem was reported. And it sucks having to copy and paste the quotes every time and that's every 20 seconds.

That was to have solved. I like paying the Sindo MonoTouch me quite angry that this is a problem until today!
Comment 9 Mikayla Hutchinson [MSFT] 2013-02-21 15:34:56 UTC
This this still a problem with Xamarin Studio (MonoDevelop 4.0)?

We have shipped the new GTK+ builds.
Comment 10 Michael Natterer 2013-02-22 04:49:09 UTC
What is the exact keyboard layout, and what key do you press? I'm really
confused here, maybe different keyboard models do things differently,
and I fixed it only for my keyboard? (Apple wireless keyboard, the small
one shipped with iMacs).
Comment 11 Michael Natterer 2013-02-22 04:52:06 UTC
Oh, did you mean to ask if this is still an issue? One of us
mis-wrote/read here :)
Comment 12 niiokai77 2013-02-24 02:14:34 UTC
It's still an issue and updates don't seem to take effect too. Unless those are background services. Downloaded the new gtk and did everything, but the quotes still don't appear with us - international or us layout
Comment 13 Mikayla Hutchinson [MSFT] 2013-02-28 00:34:35 UTC
Did you download and install Xamarin Studio 4.0 and Mono 2.10.11? What exactly is not working?
Comment 14 Joren Boulanger 2013-02-28 14:41:15 UTC
I have a similar bug:
My keyboard layout is United States (International)
Compound symbols are not working.
For example: é
I press the ' button followed by the 'e' button but only an e appears. 

When I try to write only the ' symbol, I press ' and then spacebar. But this doesn't work either. A whitespace appears in stead of the ' mark.
This is for all symbols '"`~^

Without being able to write these symbols Xamarin Studio is pretty useless. (copy-pasting the marks works though)
Xamarin Studio is the only application that has this problem. In Calibre (uses Qt) and in GIMP 2.8 it works.

Xamarin Studio 4.0 (build 2003)
Windows 7 Home Edition 64bit (Dutch)
Keyboard layout: United States (International)
Comment 15 Felipe Leusin 2013-04-23 19:35:40 UTC
Would like to say this bug also happens to me on Windows8 and the latest version of Xamarin Studio.

If I set my language as Portugues (United States - International) on Windows I can`t use any symbol.

If I set to English (US Keyboard) I can use the symbols again.

This happens only on Xamarin Studio.
Comment 16 PJ 2013-11-19 17:03:58 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 17 Mikayla Hutchinson [MSFT] 2013-11-20 14:31:52 UTC

*** This bug has been marked as a duplicate of bug 4205 ***