Bug 7180 - MT1006: "Package Extraction Failed Error (0xe8000050)" during deployment when build path contains certain characters.
Summary: MT1006: "Package Extraction Failed Error (0xe8000050)" during deployment when...
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.4.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Sebastien Pouliot
Depends on:
Reported: 2012-09-14 14:06 UTC by Yvan Rodrigues
Modified: 2012-12-04 17:26 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Build logs (15.66 KB, application/x-zip-compressed)
2012-09-14 14:06 UTC, Yvan Rodrigues

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Yvan Rodrigues 2012-09-14 14:06:06 UTC
Created attachment 2538 [details]
Build logs

Mac Mini Core i5 2.3GHz / 16GB
OS X 10.8.1
XCode 4.4.1
iPhone 3GS on 5.1.1

If the build path contains certain characters (in my case, square brackets and the pound sign), deployment to a real iOS device will fail like:

Connected to: Dilbert
Initializing file service...
Transferring application
Finalizing file service...
Installing application
Installation failed: Package Extraction Failed Error (error: 0xe8000050)
error MT1006: Could not install the application '/Users/yvan/Documents/Projects/[#12345]test/test/test/bin/iPhone/Debug/test.app' on the device: Package Extraction Failed Error (error: 0xe8000050).
The application was terminated by a signal: SIGHUP

The application will run in the simulator.

This behaviour *appears* to have only started around September 5, possibly after an XCode update.

The following notes correspond to the attachments. Each is simply a build/deploy log. In all cases I did:
Start new Solution...
MonoTouch -> Universal -> Empty Project
Change to Debug|iPhone profile.
Start Debugging

When the project below lives in folder A, I get the error.
Folder A is: /Users/yvan/Dropbox/Red Cell Innovation/Projects/[#40004] City of Guelph Tourism App/Source/Guelph.App.iOS.VisitGuelph

When I copy the solution to folder B, it works fine.
Folder B is: /Users/yvan/Documents/Projects/Guelph.App.iOS.VisitGuelph

Similarly, when I create an empty project called "test" in Folder A, I get the error, but when I create an empty project in Folder B, no problems.

With a theory that the longer path played a role, I built project C (attached). It worked fine.
Folder C is /Users/yvan/Documents/Projects/foo/bar/foo/bar/foo/foo bar foo bar foo bar foo bar/test

With a theory that it didn't like being built in a DropBox folder, I built project D. It worked fine.
Folder D is /Users/yvan/Dropbox/Red Cell Innovation/Development/test

Project E was the same as A, but one folder higher. It did NOT work.
Folder E is /Users/yvan/Dropbox/Red Cell Innovation/Projects/[#40004] City of Guelph Tourism App/test

Project F was in a different folder at the same level as E. It did NOT work.
/Users/yvan/Dropbox/Red Cell Innovation/Projects/[#50033] Poster Pals/test

Project G was in a folder at the same level as B, but with square brackets and # in the path. It did NOT work.

Hypothesis: The package extraction tool cannot cope with certain characters in the path.

I should mention that although I have 22 years experience as a programmer, I am an idiot when it comes to Macs, so maybe I'm doing something obvious wrong like having an uncool haircut or (gasp) using a PC keyboard and mouse on my Mac Mini.
Comment 1 Sebastien Pouliot 2012-09-14 14:49:09 UTC
Bonjour Yvan,

I think you nailed the problem. I'll try to duplicate it and see if it comes from MonoTouch or Xcode side (and for the later if/how we can wrok around this). Anyway we can, at least, provide a better error message about the situation.

Thanks a lot for taking the time to test and report this behaviour.
Comment 2 Sebastien Pouliot 2012-09-14 20:19:16 UTC
using '[' and ']' works but '#' fails

Installation failed: AMDeviceInstallApplication returned: 0xe8000067 (kAMDAPIInternalError)
error MT1006: Could not install the application '/Users/poupou/Projects/test#2/test2/bin/iPhone/Debug/test2.app' on the device: AMDeviceInstallApplication returned: 0xe8000067 (kAMDAPIInternalError).

My error code is different - that could be because I'm using MonoTouch 5.99.4 on Xcode 4.5 GM. Out of curiosity what version of MonoTouch are you using ?

I'll try to find a way to encode this (if possible) differently so the API will allow it.
Comment 3 Yvan Rodrigues 2012-09-15 10:01:16 UTC
I am using MonoTouch 5.4.0 build 30004006.

When this problem first started (in early September, I think after an XCode update from 4.4.0 to 4.4.1), the error code 0xe8000050 was the same, but the MT error was different; Installation failed: AMDeviceInstallApplication returned: 0xe8000050 but with no mention of package extraction failure.

I tried all kinds of things to fix it. One of them was installing XCode 4.5. This also resulted in an error at the same stage, but it was 0xe8000067 like you are getting.

It would be interesting to try rolling back to XCode 4.4.0 or earlier to see if the problem goes away. I however have already spent too much time on this and have a deadline this week.
Comment 4 Sebastien Pouliot 2012-09-15 11:46:36 UTC
Thanks for the extra details, they will prove useful. Good luck on your project!
Comment 5 Sebastien Pouliot 2012-12-04 17:26:37 UTC
Fixed in
master: 5b7c725b48d079ee463ee6defc1cff800da76627
ios6: 0ebb01884d8fc9ead32c53b5a7da8d0d901b1f99