Bug 7111 - Application crashes loading large Web Pages on a New iPad while runing fine on iPad 1 and iPad 2
Summary: Application crashes loading large Web Pages on a New iPad while runing fine o...
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: 5.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2012-09-12 14:40 UTC by Stan F.
Modified: 2013-12-05 18:35 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Stan F. 2012-09-12 14:40:40 UTC
We have a complex application which is structured as follows:

Application is presented to the user as a single App bundle, while internally it consists of 2 separate communicating entities running from within the same process.

1) UI Form hosting UIWebView control
2) Backend logic which downloads data from the Enterprise Database and dynamically generates very complex (lots of elements) HTML pages. These pages are served via a built-in mini Web Server.
3) UIWebView control is pointing to the built-in Web Browser and displays pages that are generated by the backend logic

We have found that some very large pages cause application to crash. We've tried isolating the problem and had made our application UI less pointing external browser (running on Win32 computer) to it and the page loads fine.
We also tried pointing Safair on iPad3 to our application and it loads pages fine as well. It crashes only when 2 entities running within the same process space trying to load largest pages.

We are using MonoTouch v5.2.13. I wanted to add that the same application loads all of the pages with no issues on the iPad 1 and iPad 2.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-09-12 17:32:05 UTC
Can you attach crash reports / device console output for the crashes? That might give us some idea on what's going on.

It sounds like a memory problem, but it is strange that it works on iPad 1 & 2, but not on iPad 3 (the only thing that is known to increase memory usage on an iPad 3 is the increased resolution - all images use 4x more memory). In any case the crash reports / device console output will tell us if it is a memory problem or something else.
Comment 2 Sebastien Pouliot 2012-09-13 11:01:06 UTC
The iOS version of each device would be important to know too since different versions of WebKit will be used.
Comment 5 Stan F. 2012-09-13 14:06:45 UTC
These logs were generated on New iPad running iOS 5.1.1
Comment 6 Rolf Bjarne Kvinge [MSFT] 2012-09-13 18:00:44 UTC
It is indeed a memory problem, at the end of the console log several apps get killed due to low memory.

I suggest you try to track down where the memory is used by using Instruments - or we can have a look if you can provide a test case for it.
Comment 7 PJ 2013-11-19 17:05:00 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 8 PJ 2013-12-05 18:35:21 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.