Bug 6955 - TimePicker shows old style/theme on phone with Android 4.0
Summary: TimePicker shows old style/theme on phone with Android 4.0
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 4.2.x
Hardware: Macintosh Windows
: High normal
Target Milestone: ---
Assignee: dean.ellis
Depends on:
Reported: 2012-09-06 10:54 UTC by Scott
Modified: 2013-06-20 10:48 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Scott 2012-09-06 10:54:26 UTC
Here's my situation.
I have a MacBook Pro which is running Parallels so that I can use VisualStudio 2010.

I have a Samsung Galaxy S2 with the latest firmware update:  Android 4.0.4.
I have set my test project to support minimum Android 4.0.
In the manifest, I have set the minimum api level to 14 and the targeted api level to 14.

When my test app runs in VirtualBox, I see the latest time picker with the nice arrow buttons and streamlined look.
When I deploy my test app to my phone, I see the BIG BLOCKY (UGLY) number picker buttons for the time picker.

I cannot figure out why this is happening.  I don't know if this is a runtime-error or a deployment error.
Comment 1 Miguel de Icaza [MSFT] 2013-05-22 15:19:40 UTC
Can you try adding an Android manifest file and then setting the other two Android variables that control the version that will be used?

That should fix it, if not, please reopen the bug.

We agree that the UI is confusing, we are working to fix that.

Dean will be working on the new UI to configure all the proper versions of Android in a single place, instead of requiring you jump around.
Comment 2 dean.ellis 2013-06-20 10:48:06 UTC

I have tried to replicate the issue you are seeing. 
I ran a similar app (just a TimePicker on it) on a Kindle Fire HD, Samsung Galaxy Tab 10.1 and a Nexus 7. All of which are on different versions of Android and are different manufacturers. 

I got a different time picker on each one and only the kindle fire one looked similar the one I saw on the API 15 emulator I ran up. The Galaxy Tab one looked horrible. 

I created a similar project in java and got the same results on all 3 platforms. 

I suspect that the TimePicker looks the way it does because each manufacturer is able to tweak android to look the way they want. In this case Samsung have probably done a bad job with the time picker.