Bug 6856 - Error while trying to debug application with monotouch debugger
Summary: Error while trying to debug application with monotouch debugger
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 5.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2012-09-03 06:33 UTC by Alexander Viken
Modified: 2012-09-03 08:52 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alexander Viken 2012-09-03 06:33:46 UTC
This exception suddenly appeared in the output window, Have had no problems deploying the application, when I tried to re-run the app with debugger i worked and I could not reproduce.....

---------- MonoDevelop Application Output window ------------------------------------
Please ensure your device is connected...
Connected to: Alexander Viken’s iPhone
error MT0000: Unexpected error - Please fill a bug report at http://bugzilla.xamarin.com
System.Xml.XmlException: expected '>' (3E) but found 'EOF' (FFFFFFFF)  Line 795, position 5.
at Mono.Xml2.XmlTextReader.Expect (int) <0x00163>
at Mono.Xml2.XmlTextReader.ReadStartTag () <0x003ab>
at Mono.Xml2.XmlTextReader.ReadContent () <0x0018f>
at Mono.Xml2.XmlTextReader.ReadContent () <0x001af>
at Mono.Xml2.XmlTextReader.Read () <0x0019b>
at System.Xml.XmlTextReader.Read () <0x000b7>
at System.Xml.XmlDocument.ReadNodeCore (System.Xml.XmlReader) <0x00737>
at System.Xml.XmlDocument.ReadNodeCore (System.Xml.XmlReader) <0x002d3>
at System.Xml.XmlDocument.ReadNodeCore (System.Xml.XmlReader) <0x002d3>
at System.Xml.XmlDocument.ReadNodeCore (System.Xml.XmlReader) <0x002d3>
at System.Xml.XmlDocument.ReadNode (System.Xml.XmlReader) <0x0009f>
at System.Xml.XmlDocument.Load (System.Xml.XmlReader) <0x0004f>
at System.Xml.XmlDocument.LoadXml (string) <0x000be>
at MonoTouch.Installation.Installer.KillApplication (MonoTouch.Installation.Device,string) <0x000b8>
at MonoTouch.Installation.Installer/<KillApplication>c__AnonStorey6.<>m__7 (MonoTouch.Installation.Device) <0x00017>
at MonoTouch.Installation.Installer/<ExecuteWithSession>c__AnonStorey3.<>m__2 (object,System.EventArgs) <0x000ef>
at MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0006e>
at (wrapper native-to-managed) MonoTouch.Installation.Device.NotificationCallback (MonoTouch.Installation.Device/am_device_notification_callback_info&) <0x0003f>
at (wrapper managed-to-native) MonoTouch.CoreFoundation.CFRunLoop.CFRunLoopRun () <0x00003>
at MonoTouch.CoreFoundation.CFRunLoop.Run () <0x0000b>
at MonoTouch.Installation.Installer.ExecuteWithSession (MonoTouch.Installation.Installer/Executor) <0x000cf>
at MonoTouch.Installation.Installer.KillApplication (string) <0x0005f>
at MTouch.Main2 (string[]) <0x03c27>
at MTouch.Main (string[]) <0x0001f>
------------------- MonoDevelop Application Output -------------------------------------------------

Installation UUID: 8119cc82-3c0f-4a49-9636-f153c942a72d
	Mono 2.10.9 (tarball)
	GTK 2.24.10
	GTK# (
	Package version: 210090011
Apple Developer Tools:
	 Xcode 4.4.1 (1488)
	 Build 4F1003
Monotouch: 5.2.13
Mono for Android:
Android SDK: /Users/alexander-viken/Library/Developer/Xamarin/android-sdk-mac_x86
Supported Android versions:
	Version: 1.6	ApiLevel: 4
	Version: 2.1	ApiLevel: 7
	Version: 2.2	ApiLevel: 8
	Version: 2.3	ApiLevel: 10
	Version: 3.1	ApiLevel: 12
	Version: 4.0	ApiLevel: 14
	Version: 4.0.3	ApiLevel: 15
Java SDK: /usr/bin

Build information:
	Release ID: 30003005
	Git revision: 3d53e1366933298a3fe0cdc6d0f7d00c9916564c-dirty
	Build date: 2012-07-27 19:06:34+0000
	Xamarin addins: 73ecde7c48d943adb6e33d511d3cf0661d006801
Operating System:
	Mac OS X 10.8.1
	Darwin alexanders-imac.office.osl.modirum.com 12.1.0 Darwin Kernel Version 12.1.0
	    Tue Aug 14 13:29:55 PDT 2012
	    root:xnu-2050.9.2~1/RELEASE_X86_64 x86_64
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-09-03 08:52:23 UTC
This has been fixed in the 5.3+ series. If it is not reproducible (i.e. hindering your workflow) don't worry about it since it will be fixed in the 5.4 release.