Bug 6595 - Crash at startup (splash screen)
Summary: Crash at startup (splash screen)
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 3.0.x
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2012-08-18 06:52 UTC by Matthias Volmer
Modified: 2012-08-18 20:07 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Matthias Volmer 2012-08-18 06:52:01 UTC
MonoDevelop crashes right at startup with the splash screen shown and the progress bar stuck at 0. CPU usage goes right up to around 90%.

The first time I started MonoDevelop it went just fine. Before I started it a second time, there were two things that I did:
-> installed Version Control
-> tried running MD directly by opening a .sln file

Since then it's stuck, but I don't know if it's related.

I also tried
-> monodevelop -nologo
but this starts MD _with_ splash screen and with the same problem
-> mdtool gsetup
this has a similar symptom in that it hangs and the CPU usage goes all the way up. No error messages or any other things are displayed.

I'm running from Badgerports on Linux Mint 13 - Xfce release.

Will try to give it a fresh install and see what happens.

- Matthias
Comment 1 Matthias Volmer 2012-08-18 07:50:42 UTC

I have completely reinstalled MonoDevelop a few times now and finally got it to start up normally again. Removing all MD files from the /home/.chache/ folder seems to have done the trick.

I also reinstalled the Version Control plug-in, and I ran MD directly by opening an .sln file. Neither of the two seems to have any negative effects.

Bottom line:

MonoDevelop is starting fine now and I cannot reproduce the bug.

- Matthias
Comment 2 Mikayla Hutchinson [MSFT] 2012-08-18 20:07:10 UTC
We'll close the bug for now, we can't do anything until we have a repro case or crash/hang traces.

For reference, here's how to get hang traces: http://monodevelop.com/Developers/Reporting_Bugs#Debugging_Hangs_on_Mac_and_Linux