Bug 6532 - UI Designer intermittently not display when opening an axml file in VS2010
Summary: UI Designer intermittently not display when opening an axml file in VS2010
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: PJ
: 7256 ()
Depends on:
Reported: 2012-08-14 16:21 UTC by Peter Collins
Modified: 2016-08-03 15:24 UTC (History)
8 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Peter Collins 2012-08-14 16:21:02 UTC
Spent a few hours working with this issue, was able to reproduce 2 times out of 7 on two different Windows 7 VMs. Initially the Win7x32 failed to display the designer in VS2010 on both MFA 4.2.4 and 4.2.5 two times in a row. I then attempted to reproduce this on Win7x64 and was unable to repro. Finally, I went back to the Win7x32 to attempt another repro and was unable to reproduce this issue 3 times in a row using both MFA 4.2.4 and 4.2.5. 

Environment Details:
Win7x32 and Win7x64
Visual Studio 2010
MD and
MFA 4.2.4 and 4.2.5

Reproduced on:
Visual Studio 2010
MFA 4.2.4 and 4.2.5

Issue Stems from:
Comment 1 Chris Hardy [MSFT] 2012-09-12 11:48:30 UTC
To find out more information on the issue, we will need to do the following:

* Start Visual Studio as an Administrator (right click on the VS icon in the start menu and select "Run as Administrator")
* Click on the option File->Open->Project/Solution in the main menu
* Select the path to the Visual Studio executable. It should be something like "C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe". Select devenv.exe in the open file dialog.
* Click on the option Debug->Start Debugging
* At this point a new Visual Studio instance will be started.
* In the new VS instance, create a new Mono for Android project, and once created try opening the layout Main.axml
* In the first VS instance, click on View -> Output. You should see the output window with a lot of text. Please copy all that text to a file and attach it to this bug.

When I ran the following commands, this fixed the issue and the VS 2010 then showed the designer as expected...
Comment 2 PJ 2012-09-12 12:06:27 UTC
Chris is there any additional information that can be gleaned from other cases (besides the one in comment 1)? 

The issue that PeterC was able to reproduce stemmed from an incorrectly generated .axml file. We are still unable to get a reproduction of the real issue.

Perhaps the intermittent issue was fixed in the AndroidDesigner.jar changes that lluis did just before the 4.2.5 release?

Has this issue been reported again recently?
Comment 3 Chris Hardy [MSFT] 2012-09-12 12:29:01 UTC
The way I experienced this issue was installing Windows 8 RTM, installing VS 2012 and MfA 4.2.4.

I then needed to get VS2010 installed so I did that and then upgraded to MfA 4.2.5 through Visual Studio 2012, this then meant that Visual Studio 2010 didn't allow the Designer to load up nor did it show up in the "Open With..." for a AXML file (whilst it worked fine in 2012). Running the steps above then caused the designer to load up and subsequent projects/openings of Visual Studio 2010 allowed this to work.
Comment 5 Lluis Sanchez 2012-09-19 12:48:59 UTC
Fixed in the 4.2.6 branch. Fix coming to master soon.
Comment 6 Lluis Sanchez 2013-08-29 12:28:26 UTC
*** Bug 7256 has been marked as a duplicate of this bug. ***