Bug 6395 - Debugger does not launch application
Summary: Debugger does not launch application
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 5.3.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2012-08-04 15:50 UTC by Basarat
Modified: 2012-08-07 10:19 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Basarat 2012-08-04 15:50:17 UTC
The monotouch debugger does not launch the application. I am debugging using usb. The issue started after I upgraded to mountain lion and Xcode 4.4.

I get the following in Application Output: 

MonoTouch.MobileDevice.MobileDeviceException: Invalid Disk Image Error (error: 0xe8000033)
  at MonoTouch.Installation.Device.MountDeveloperImage () [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer.KillApplication (MonoTouch.Installation.Device d, System.String appId) [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer+<KillApplication>c__AnonStorey7.<>m__8 (MonoTouch.Installation.Device d) [0x00000] in <filename unknown>:0 

And I get the message "Waiting for debugger to connect". It only connects after I manually launch the application on the iphone.

Its iPhone 4 with version 4.1 installed.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-08-04 16:11:37 UTC
Have you tried restarting the device?
Comment 2 Basarat 2012-08-05 02:31:50 UTC
I have restarted the device as well as the computer. 
I have also tried to uninstall the application from the device. It reinstalls fine when I click debug in monodevelop. Just doesn't launch on its own.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2012-08-06 13:51:23 UTC
I'm not entirely sure Xcode 4.4 supports iOS < 4.3.

Can you try to create a hello world with Xcode and see if you can run it on your device?
Comment 4 Basarat 2012-08-07 10:19:12 UTC
Everything is working again. Sorry to be a bother. In case other people face the same issue:

Xcode 4.4 could not launch. So I unisntalled and tried installing 4.3. Only to find that it will not install on mountain lion. So reinstalled Xcode 4.4. Still did not debug. Restarted phone again. Error description in Xcode changed. So restarted mac. Xcode could debug. 

Started monodevelop, and its working again. 

Restarting everything alone did not fix it. 
Basically i think Uninstall / Reinstalling Xcode (as opposed to upgrade) and restarting everything fixed it.