Bug 6331 - CGAffineTransform fields incorrectly named
Summary: CGAffineTransform fields incorrectly named
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: 5.3.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2012-07-30 20:06 UTC by Stuart Carnie
Modified: 2012-07-31 07:50 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Stuart Carnie 2012-07-30 20:06:38 UTC
From CGAffineTransform.h:

struct CGAffineTransform {
  CGFloat a, b, c, d;
  CGFloat tx, ty;

However in MonoTouch they are named yy, x0, y0, xx, yx, xy
Comment 1 Sebastien Pouliot 2012-07-31 07:50:09 UTC
In general we strive to keep the same names to ease porting existing Objective-C code (e.g. samples) and reading documentation.

There are a few exceptions, e.g. Rectangle[F], Size[F}, Point[F] which uses System.Drawing-like names (instead of CGRect, CGSize and CGPoint) where we think .NET developers were more likely to know existing (and identical) structures.

This one is a bit similar, the "well know" (at least to most old Mono users) Cairo's matrix member names were used (maybe even without realizing it, I never noticed it before ;-).

However we won't be changing them to ensure source compatibility (and even binary compatibility wrt reflection/serialization) with earlier MonoTouch releases. 

Still thanks for reporting the issue as we can, sometime, fix bad names ([Obsolete] them) and replace them with more useful overloads (it's easier on methods than fields).