Bug 6261 - 4.2.4 Designer destroys xaml files.
Summary: 4.2.4 Designer destroys xaml files.
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: High major
Target Milestone: ---
Assignee: Lluis Sanchez
Depends on:
Reported: 2012-07-24 15:23 UTC by NeoDarque
Modified: 2016-08-03 15:24 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description NeoDarque 2012-07-24 15:23:30 UTC
Randomly the designer totally destroys the .axml file (erasing part of the file at the end) when opening the .axml file.

This seems to happen more frequently when having edited the .axml file in the xml editor (normal visual studio xml editor) before opening the same file in the designer.

Since this requires the user roll back to an earlier commited version of the same file it makes the whole process of working with the designer too much of a pain to be worthwhile, hence I tend to not use it anymore.

It's ok to put up an error message in case the designer isn't developed enough to handle the xml, but it certainly isn't ok to just shred source files.

I've tried working with the designer in MonoDevelop and there I haven't seen any of these problems.
Comment 1 Lluis Sanchez 2013-03-11 06:34:58 UTC
Are you still seeing this problem with Xamarin.Android 4.6?
Comment 2 NeoDarque 2013-03-12 16:25:52 UTC
I have only used MonoDevelop lately, but I worked in VisualStudio for a day now, and no I didn't see this problem anymore in VisualStudio with Xamarin.Android 4.6.
Comment 3 Lluis Sanchez 2013-03-20 07:05:40 UTC
OK, closing for now.
Comment 4 Jatin 2013-03-25 03:01:23 UTC
Today, with the latest builds:

VS 2012/2010
MFA 4.6.01079
Mono 2.10.12

And now the issue does not exists. As the designer is working fine for VS as well as for XS.

Hence, closing this issue.