Bug 625 - Issue with hot-keys correctly being picked up in a non-english language
Summary: Issue with hot-keys correctly being picked up in a non-english language
Status: RESOLVED DUPLICATE of bug 5162
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.6 RC 1
Hardware: PC Linux
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
: 802 3230 ()
Depends on:
Reported: 2011-09-04 10:23 UTC by Chris Hardy [MSFT]
Modified: 2012-11-14 18:27 UTC (History)
5 users (show)

Tags: gtk
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Chris Hardy [MSFT] 2011-09-04 10:23:37 UTC
There is a problem with hot-keys, when current language is non-English. It's really annoying. =(

I mean, when I switch to my native language (Russian) to write some code comment and then I press some hotkey (Ctrl-S, Ctrl-X, etc) nothing happens. It takes some time and some more pressing of the same hot-key to understand the issue. Then I have to switch back to English, to press desired HK, to switch back to Russian.

It's too complex. Too time consuming. =(
Comment 2 Mike Krüger 2011-12-09 04:29:58 UTC
*** Bug 802 has been marked as a duplicate of this bug. ***
Comment 3 Mike Krüger 2012-02-06 08:24:11 UTC
*** Bug 3230 has been marked as a duplicate of this bug. ***
Comment 4 Mike Krüger 2012-03-28 08:09:05 UTC
Hotkeys are part of the shell - moving to general.
(It's a gtk issue - keyboard input is atm broken, we're working on it, but it's nothing that will change anytime soon)
Comment 5 Ruda 2012-09-19 12:16:52 UTC
How boring it.
Already have years and this problem is not solved.
Pay to have the MonoTouch and I have to be copying and pasting the double quotes because MonoDevelop does not work properly.

The problem will be solved when?
Comment 6 Mikayla Hutchinson [MSFT] 2012-11-14 18:27:31 UTC

*** This bug has been marked as a duplicate of bug 5162 ***