Bug 6128 - Can't load project in VS
Summary: Can't load project in VS
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2012-07-15 12:39 UTC by patrickdengler
Modified: 2016-08-03 15:22 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description patrickdengler 2012-07-15 12:39:58 UTC
I am losing my mind! I had this working and then I must have installed something wrong, so I tried to rollback.  Now, not even the example program will load.  HOwever, I should note that potentially the instller isn't working as when I run it, when it goes to scan for installed components I get:

[2012-07-15 16:39:29.128] [Debug] Detection completed.
[2012-07-15 16:39:29.132] [Info] Status: aborted by user
[2012-07-15 16:39:29.136] [Info] No software needs to be installed.

However, i have installed this a million times so maybe it is correct?

C:\Users\Public\MonDevelop\MonoGame\MonoGame.Framework\MonoGame.Framework.Android.csproj : error  : The project file 'C:\Users\Public\MonDevelop\MonoGame\MonoGame.Framework\MonoGame.Framework.Android.csproj' cannot be opened.

The project type is not supported by this installation.

C:\Users\Public\MonDevelop\MonoGame\ThirdParty\Lidgren.Network\Lidgren.Network.Android.csproj : error  : The project file 'C:\Users\Public\MonDevelop\MonoGame\ThirdParty\Lidgren.Network\Lidgren.Network.Android.csproj' cannot be opened.

The project type is not supported by this installation.
Comment 1 Jonathan Pryor 2012-07-16 14:58:57 UTC
Does one of these files exist?

C:\Program Files\MSBuild\Novell\Novell.MonoDroid.Common.targets
C:\Program Files (x86)\MSBuild\Novell\Novell.MonoDroid.Common.targets

You could try downloading the Mono for Android .msi from https://store.xamarin.com/account/products and re-install Mono for Android. Please make sure that Visual Studio is closed before installing Mono for Android.
Comment 2 PJ 2013-05-13 18:02:44 UTC
Heyo Patrick, hope you've gotten things working. Resolving as NORESPONSE for now, please feel free to REOPEN if you are still experiencing the issue.