Bug 61243 - Facing issue with exception in Magtek device Dll is Foundation.ModelNotImplementedException
Summary: Facing issue with exception in Magtek device Dll is Foundation.ModelNotImplem...
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2018-02-28 17:24 UTC by Tusshar
Modified: 2018-03-07 02:12 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Tusshar 2018-02-28 17:24:39 UTC
Hi All,
      I am making the native binding library of Magtek SDK And i have made DLL file but facing issue with an exception taht because my application not working properly, and the Exception is Foundation.ModelNotImplementedException: Exception of type  'Foundation.ModelNotImplementedException' was thrown.S So, Please look into this and help me with that, the sample application I have attached with this Bug Report.
Comment 1 Manuel de la Peña [MSFT] 2018-03-01 17:42:34 UTC

It looks like there is no attachment in the bug report, therefore we cannot reproduce it. Also, we would need, with the attachment, the full information of you environment.

The easiest way to get exact version information:
- On Visual Studio for Mac: "Visual Studio" menu, "About Visual Studio" item, "Show Details" button.
- On Visual Studio for Windows: "Help menu", "About Microsoft Visual Studio" item.
Then copy/paste the version information (you can use the "Copy Information" button).
Comment 2 Tusshar 2018-03-05 10:10:07 UTC
   Below is the URL to download my sample application:

In this application I have made DLL file with name Magtek.iDynamo and referenced in Sample App , But while I am building my application it's giving me same error as in this Bug Report I have mentioned.
Comment 3 Tusshar 2018-03-05 10:11:14 UTC
And, the visual studio information also I have attached in that URL.
Comment 4 Manuel de la Peña [MSFT] 2018-03-05 18:13:36 UTC
The problem you have is an issue with the binding you are created and not a bug with the platform. I recommend you ask in the xamarin forums on how to do the binding of the model, another user is facing something similar in this post:


He is looking at  MTSCRA too. Please take a look. Other resources that will be useful in you case can be found in our documentation:

Comment 5 Tusshar 2018-03-06 12:02:28 UTC
okay , But I have tried in my code with implemented same, still facing same issue. So, Please help me with that. I am unable to find any resolution about this.

Comment 6 Vincent Dondain [MSFT] 2018-03-07 02:12:09 UTC

Manuel pointed you to the forums in https://bugzilla.xamarin.com/show_bug.cgi?id=61243#c4 because bugzilla isn't a support channel it is for bugs specific to Xamarin.iOS. Note that the forum post in comment 4 is relevant, I'm seeing the same problem when trying your app. Please ask on the forums for help with your binding project.

Otherwise the broader developer community would be the best and quickest place for additional troubleshooting help on this issue.
Posting a question on Stack Overflow [0] or the Xamarin Forums [1][2] would be the best next step.

[0] https://stackoverflow.com/questions/tagged/xamarin
[1] https://forums.xamarin.com/categories/ios
[2] https://forums.xamarin.com/categories/mac

(Investigation by the Xamarin team in the bug tracker for an issue like this would usually require that the reporter include additional background info to hint that Xamarin is behaving differently compared to Xcode.)

In case it might also be a helpful reference, you can find some general recommendations on the best places to ask various kinds of questions about Xamarin on: