Bug 61203 - Markdown Readme file not presented in component
Summary: Markdown Readme file not presented in component
Status: NEW
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.7.0 (15.4)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2018-02-02 12:37 UTC by Matthias Hochrieser
Modified: 2018-02-02 12:39 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 61203 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:

Description Matthias Hochrieser 2018-02-02 12:37:44 UTC
I have a GettingStarted.md file in my component. I reference the file in the component.yaml file like this:

getting-started: ./docs/GettingStarted.md

And it works. The files is within the component, when the component is created. But recently I saw a problem, which occurs from time to time: Visual Studio is unable to "parse" the markdown file and shows no getting started file when opening the component.

I currently install the component via xamarin-component.exe and this worked already several times, but sometimes when I make changes to the readme nothing works anymore. The last time I had to invest 3 hours do find out that VS is unable to parse this file. In my case the problem was a non-existing new line in front of a listing. THIS IS CRAZY!

So following example in a markdown file worked:

Hey I want to make a really cool list after this double point:

- List Item 1
- List Item 2
- Yay

The following example does not work:

Hey I want to make a really cool list after this double point:
- List Item 1
- List Item 2
- Yay

The reason why I am not reporting this bug is that I have AGAIN this problem that the Readme is not visible anymore and I have to drill down the problem. All online markdown viewers have no problem, but still Visual Studio has. This is really annoying, as there is no exception whatsoever.
Comment 1 Matthias Hochrieser 2018-02-02 12:39:56 UTC
Sorry - last sentence should be: The reason why I am reporting this bug ..