Bug 61163 - Error trying to create emulator
Summary: Error trying to create emulator
Status: NEW
Alias: None
Product: Xamarin Android Player
Classification: Xamarin
Component: Device Manager ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2018-01-19 15:05 UTC by Ricardo Almeida
Modified: 2018-04-26 08:07 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Error screenshot (55.02 KB, image/png)
2018-01-19 15:05 UTC, Ricardo Almeida
Xamarin Android Device Manager error log (50.20 KB, text/plain)
2018-02-16 03:26 UTC, Franco Tiveron
log file (1.93 KB, application/octet-stream)
2018-04-09 23:05 UTC, LeoJHarris
Emulator error message (33.48 KB, image/png)
2018-04-10 00:41 UTC, LeoJHarris
Options I checked that solved the problem for me. (106.84 KB, image/jpeg)
2018-04-26 08:06 UTC, GoodSyrup
Options I checked that solved the problem for me. (160.25 KB, image/jpeg)
2018-04-26 08:07 UTC, GoodSyrup

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 61163 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Ricardo Almeida 2018-01-19 15:05:24 UTC
Created attachment 26104 [details]
Error screenshot

When trying to create a new Emulator using Xamarin Device Manager, the following error shows up "AVD failed to create with error : AVD Manager has returned non-zero exit code: 1. Please check logs for more information. Please file a bug at Xamarin Bugzilla."

Any help is appreciated. Thanks.
Comment 1 Franco Tiveron 2018-02-16 03:26:15 UTC
Created attachment 26178 [details]
Xamarin Android Device Manager error log
Comment 2 Franco Tiveron 2018-02-16 03:27:06 UTC
Comment on attachment 26178 [details]
Xamarin Android Device Manager error log

Same issue here, log zip attached
Comment 3 Lee M 2018-03-30 01:28:18 UTC
I've run in to the same issue when creating an AVD from an already installed system image.

The logs appear to be looking for the wrong path: "StandardOutput: ERROR: JAVA_HOME is set to an invalid directory: C:\Program Files (x86)\Java\jre1.8.0_131"

My java directory is: "C:\Program Files (x86)\Java\jdk1.8.0_131", temporarily changing the folder name from jdk1.8.0_131-> jre1.8.0_131 allows me to install without any issues.
Comment 4 LeoJHarris 2018-04-09 23:03:28 UTC
Same issue here, I have installed the system image but wont create the emulator instance.
Comment 5 LeoJHarris 2018-04-09 23:05:39 UTC
Created attachment 26252 [details]
log file
Comment 6 LeoJHarris 2018-04-10 00:41:40 UTC
Created attachment 26253 [details]
Emulator error message

I thought may might work on another machine but no such luck. Different error message this time. 

I simply create the emulator this time and it downloads the required system x86 image and then I click start and an error message appears shortly after. Why is this happening?? Everything is installed correctly. The Xamarin Android Device Manager seems completely broken at the moment.
Comment 7 GoodSyrup 2018-04-26 08:01:48 UTC
After updating Visual Studio 2017 to version 15.6.6 all my Android Virtual Devices (AVD) were lost. I couldn't add new ones because of the same issue (topic of this post). I've tried anything for hours, even a reinstall of the whole system and tools. The solution for me was just two little changes. Just run Xamarin Android Device Manager and check the options like in these screenshots.
Comment 8 GoodSyrup 2018-04-26 08:06:18 UTC
Created attachment 26285 [details]
Options I checked that solved the problem for me.
Comment 9 GoodSyrup 2018-04-26 08:07:12 UTC
Created attachment 26286 [details]
Options I checked that solved the problem for me.