Bug 61092 - Simulator does not refresh to show accurate representation of a view that is visible
Summary: Simulator does not refresh to show accurate representation of a view that is ...
Alias: None
Product: Windows iOS Simulator
Classification: Xamarin
Component: Simulator ()
Version: 1.2
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-12-13 20:10 UTC by John Miller [MSFT]
Modified: 2018-03-13 13:55 UTC (History)
11 users (show)

Is this bug a regression?: ---
Last known good build:

Video of refresh issue (583.98 KB, video/mp4)
2017-12-13 20:39 UTC, Jeff
Sample project (407.48 KB, application/x-zip-compressed)
2017-12-14 18:08 UTC, Jeff
PC/Mac logs from trying to run sample app remoted on a 6s on PC (7.20 KB, application/x-zip-compressed)
2017-12-14 18:22 UTC, Jeff
Version and Video Rendering Issue iOS Sim (192.33 KB, application/zip)
2017-12-29 14:31 UTC, Bernard Blanckaert
Screenshot of refresh issue (27.52 KB, image/png)
2018-01-30 11:08 UTC, Tomasz Telepko
Screenshot of refresh issue (144.13 KB, image/png)
2018-02-22 20:41 UTC, José Luis
Information requested of refresh image issue (1.27 MB, application/x-zip-compressed)
2018-02-23 19:10 UTC, José Luis

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 61092 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:

Description John Miller [MSFT] 2017-12-13 20:10:51 UTC
## Overview

Filing on behalf of some user reports in DevCom and the Forums. 

Users report that the remote simulator is not showing an accurate representation of a view that it should be showing. It's like the remote simulators preview is not up-to-date or refreshed. 

## Version Information

Latest 15.5.1 on Windows and Mac
Remoted Sim
Xcode 9.2

## Additional Information

Forums thread: https://forums.xamarin.com/discussion/comment/311821#Comment_311821
Attached are logs from the forums post
Comment 3 Jeff 2017-12-13 20:39:21 UTC
Created attachment 25999 [details]
Video of refresh issue

This is a video I made of the simulator showing the refresh issue. I made a template Xamarin cross platform iOS app and didn't change any of the settings at all (except to make it a regular Xamarin app instead of Xamarin.Forms). You can see that the first label doesn't refresh and disappear after being clicked on. Upon going to the home screen and then back, it correctly refreshes.
Comment 4 sauron 2017-12-14 00:17:33 UTC
Today i updated to latest version of everything after two months of not doing anything on my project and i found myself having the same issue.
Comment 5 sauron 2017-12-14 00:22:10 UTC
Also, this issue happens with the simulator on mac and with the remote one on windows.
Comment 6 Alan McGovern 2017-12-14 10:21:51 UTC
Since the same issue is showing up in the remoted simulator on Windows and when using Apple's simulator on the Mac, 
then the issue is either a bug in iOS itself or a bug in your application. Either way - if the remote simulator on Windows works the same way as Apple's simulator on Mac then this should be considered the expected behaviour and everything is working.

If you come across an issue where the remoted simulator differs in behaviour from Apple's one on the Mac then please let us know and we'll investigate the problem!


(also if you can share a test case on stack overflow, the xamarin forums, or here, then someone may be able to figure out what the issue is).
Comment 7 Alan McGovern 2017-12-14 13:14:17 UTC
Sorry - I just realised there were two different people on the bug report.

Sauron - my previous comment was about your issue.

Jeff - can you share an app which reproduces the problem so we can diagnose what's going on?

Comment 8 jgmachado10 2017-12-14 13:38:54 UTC

I am having the same issue.

Remote simulator is not refreshing ok. but when i go to use the mac simulator it shows ok !!!

Thanks !!!
Comment 9 John Miller [MSFT] 2017-12-14 13:52:29 UTC
For those who are also experiencing this issue. Here is what you can include in a .zip attached to this bug report to help us investigate:

* Version information from Windows and Mac. 
The easiest way to get exact version information:
- On Visual Studio for Mac: "Visual Studio" menu, "About Visual Studio" item, "Show Details" button.
- On Visual Studio for Windows: "Help menu", "About Microsoft Visual Studio" item.
Then copy/paste the version information (you can use the "Copy Information" button).

* Logs
From the Mac:

The simplest way to get access to them is to start the 'Console' application (not the Terminal application!) and go to the 'Simulator.Server' folder under the 'Xamarin' node  which is under the '~/Library/Logs' node.
From Windows:
Copy the files from C:\Users\Username\AppData\Local\Xamarin\Logs\Xamarin.Simulator\  

* Sample project
Include a .zip of the project you are using to reproduce this issue. 

* Screenshots/Videos of the problem

Comment 10 jgmachado10 2017-12-14 15:33:28 UTC
I had fixed this issue deleting and creating the device simulator in Xcode 9.2
Apparently it is ok for now.
Comment 11 Jeff 2017-12-14 18:05:23 UTC
The behavior is different for me on the Mac simulator versus the Windows remoted simulator. To reproduce this I'm just using a stock Xamarin app, I haven't done anything whatsoever to the code. My steps to make said app:
File->New Project->Cross-Platform (under Visual C#)->Cross-Platform App (Xamarin.Forms)->OK->Blank App->Uncheck Android and UWP (leave iOS checked)->Native UI Technology->.NET Standard Code Sharing Technology.

I'll attach a zip of said project after this comment. As for requested information:

VS Windows:
Microsoft Visual Studio Professional 2017 
Version 15.5.1
Microsoft .NET Framework
Version 4.7.02556

Installed Version: Professional

Visual Basic 2017   00369-60000-00001-AA830
Microsoft Visual Basic 2017

Visual C# 2017   00369-60000-00001-AA830
Microsoft Visual C# 2017

Visual C++ 2017   00369-60000-00001-AA830
Microsoft Visual C++ 2017

Visual F# 4.1   00369-60000-00001-AA830
Microsoft Visual F# 4.1

Application Insights Tools for Visual Studio Package   8.10.01106.1
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2017   15.0.31125.0
ASP.NET and Web Tools 2017

ASP.NET Core Razor Language Services   1.0
Provides languages services for ASP.NET Core Razor.

ASP.NET Web Frameworks and Tools 2017   5.2.51007.0
For additional information, visit https://www.asp.net/

Azure App Service Tools v3.0.0   15.0.31106.0
Azure App Service Tools v3.0.0

Common Azure Tools   1.10
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

Fabric.DiagnosticEvents   1.0
Fabric Diagnostic Events

ILSpy.AddIn   1.0
Integration of the ILSpy Decompiler into Visual Studio.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

JavaScript UWP Project System   2.0
JavaScript UWP Project System

JetBrains ReSharper Ultimate 2017.1.1    Build 108.0.20170407.122957
JetBrains ReSharper Ultimate package for Microsoft Visual Studio. For more information about ReSharper Ultimate, visit http://www.jetbrains.com/resharper. Copyright © 2017 JetBrains, Inc.

Merq   1.1.17-rc (cba4571)
Command Bus, Event Stream and Async Manager for Visual Studio extensions.

Microsoft Azure Service Fabric Tools for Visual Studio   1.8
Microsoft Azure Service Fabric Tools for Visual Studio

Microsoft Azure Tools   2.9
Microsoft Azure Tools for Microsoft Visual Studio 2017 - v2.9.51120.3

Microsoft Continuous Delivery Tools for Visual Studio   0.3
Simplifying the configuration of continuous build integration and continuous build delivery from within the Visual Studio IDE.

Microsoft JVM Debugger   1.0
Provides support for connecting the Visual Studio debugger to JDWP compatible Java Virtual Machines

Microsoft MI-Based Debugger   1.0
Provides support for connecting Visual Studio to MI compatible debuggers

Microsoft Visual C++ Wizards   1.0
Microsoft Visual C++ Wizards

Microsoft Visual Studio Tools for Containers   1.1
Develop, run, validate your ASP.NET Core applications in the target environment. F5 your application directly into a container with debugging, or CTRL + F5 to edit & refresh your app without having to rebuild the container.

Microsoft Visual Studio VC Package   1.0
Microsoft Visual Studio VC Package

Mono Debugging for Visual Studio   4.8.4-pre (3fe64e3)
Support for debugging Mono processes with Visual Studio.

NuGet Package Manager   4.5.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

SQL Server Data Tools   15.1.61710.120
Microsoft SQL Server Data Tools

TypeScript Tools   15.5.11025.1
TypeScript Tools for Microsoft Visual Studio

Visual Assist   
For more information about Visual Assist, see the Whole Tomato Software website at http://www.WholeTomato.com. Copyright (c) 1997-2017 Whole Tomato Software, Inc.

Visual C++ for Cross Platform Mobile Development (Android)   15.0.27005.02
Visual C++ for Cross Platform Mobile Development (Android)

Visual C++ for Cross Platform Mobile Development (iOS)   15.0.27005.02
Visual C++ for Cross Platform Mobile Development (iOS)

Visual Studio Code Debug Adapter Host Package   1.0
Interop layer for hosting Visual Studio Code debug adapters in Visual Studio

Visual Studio Tools for CMake   1.0
Visual Studio Tools for CMake

Visual Studio Tools for Unity
Visual Studio Tools for Unity

Visual Studio Tools for Universal Windows Apps   15.0.27128.01
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

VisualStudio.Mac   1.0
Mac Extension for Visual Studio

WebJobs Tools v1.0.0   15.0.31201.0
WebJobs Tools v1.0.0

Xamarin (6575bd113)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin Designer   4.8.183 (2577c82ea)
Visual Studio extension to enable Xamarin Designer tools in Visual Studio.

Xamarin.Android SDK (HEAD/9cfa7836b)
Xamarin.Android Reference Assemblies and MSBuild support.

Xamarin.iOS and Xamarin.Mac SDK (6857dfc)
Xamarin.iOS and Xamarin.Mac Reference Assemblies and MSBuild support.

VS Mac:
=== Visual Studio Professional 2017 for Mac ===

Version 7.3 (build 799)
Installation UUID: c9ec33c3-f60d-4d75-b748-f4c6003940a1
	Mono (2017-06/e66d9abbb27) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 504010007

=== NuGet ===


=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Version: 2.0.0
SDK: /usr/local/share/dotnet/sdk/2.0.0/Sdks
SDK Version: 2.0.0
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.4.1/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.6.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 9.2 (13772)
Build 9C40b

=== Xamarin.iOS ===

Version: (Visual Studio Professional)
Hash: 6857dfcc
Branch: xcode9.2
Build date: 2017-12-04 21:20:41-0500

=== Xamarin.Android ===

Version: (Visual Studio Professional)
Android SDK: /Users/jeff/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		6.0 (API level 23)

SDK Tools Version: 25.2.5
SDK Platform Tools Version: 25.0.5
SDK Build Tools Version: 25.0.3

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:

=== Xamarin Inspector ===

Not Installed

=== Xamarin.Mac ===

Version: (Visual Studio Professional)

=== Build Information ===

Release ID: 703000799
Git revision: df590420ea5bc681994baefff2eabdaad889fba9
Build date: 2017-12-05 09:23:45-05
Xamarin addins: 51068d6eaf3b6fb4fbc72b33cb869b0ebff04ec5
Build lane: monodevelop-lion-d15-5

=== Operating System ===

Mac OS X 10.12.6
Darwin 16.7.0 Darwin Kernel Version 16.7.0
    Thu Jun 15 17:36:27 PDT 2017
    root:xnu-3789.70.16~2/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Internet of Things (IoT) development (Preview) 7.1

I've already tried deleting/creating the simulators to no avail.
Comment 12 Jeff 2017-12-14 18:06:30 UTC
I should note that by different behavior I meant that the sample project on the Mac simulator works perfectly but on the PC I get the behavior you see in the video I posted where it doesn't refresh correctly.
Comment 13 Jeff 2017-12-14 18:08:55 UTC
Created attachment 26008 [details]
Sample project

This is a stock Xamarin iOS template project with no code modifications at all. It runs perfect in the simulator but has refresh issues, as shown in my video I attached earlier, on the PC simulator.
Comment 14 Jeff 2017-12-14 18:22:59 UTC
Created attachment 26009 [details]
PC/Mac logs from trying to run sample app remoted on a 6s on PC
Comment 15 sauron 2017-12-14 18:25:12 UTC
I was using MacOS on VMWare Workstation and had this issue with Sierra and high Sierra after updating to xcode 9.2 everything was working fine before.
So today i went back to my old MacMini, installed everything and simulator is working fine on windows. I changed nothing on windows.

Maybe it helps you.
Comment 16 Dominic Breeze 2017-12-27 21:45:59 UTC
I'm having rendering issues with the simulator as well. I have a navigation master/detail page app. If you open the hamburger menu, the screen just shows gibberish. Full of lines. If you get lucky you might see part of the menu. The only way around it is to press the home button on the simulator menu, then tap the app icon to bring it back into focus. The entire screen is then refreshed and you can move forward. If you re-open the menu, again the screen completely distorts. The above workaround brings it all back into focus.

I also saw something similar in a stock carouselview Xamarin demo app. It had the option for None, Tabs or Dots. If you select Tabs, the app will display and you can swipe the colors around, but the Tab bar doesn't update. Likewise if you press the tab icon, nothing seems to happen. Press the simulator home button, then bring the app back into focus and voila there is the correct display. The write tab is selected and the correct color shown.

This has been going on since 15.5 at the start of December. The Mac and PC are on the same network switch. Both are physical machines. All the advertised updates are deployed for Xcode and VisualStudio on both the PC and the Mac. (Mac is not running High Sierra yet).

PC has VS 15.5.2. The situation was even worse with 15.5. 15.5.1 helped as did 15.5.2. 15.5 was just giving up. If you saw the app, and clicked main menu, it just died, black screen, spinning wheel. 15.5.1 got past that, but still not working right even with 15.5.2.

I did re-install the iOS Simulator earlier in December. I also ran a full repair of VS on the PC thinking that might help.
Comment 17 Bernard Blanckaert 2017-12-29 14:29:28 UTC
For me, the rendering issues are purely happening on my mac development environment, regardless of which simulated iOS device I choose. No Windows involved. See attachment for version and video.
Comment 18 Bernard Blanckaert 2017-12-29 14:31:02 UTC
Created attachment 26057 [details]
Version and Video Rendering Issue iOS Sim
Comment 19 Tomasz Telepko 2018-01-30 11:08:09 UTC
Created attachment 26141 [details]
Screenshot of refresh issue

I've got the same issue, simulator on OSX works fine, but remote simulator on Windows doesn't refresh correctly, sample screenshot attached.

Fortunately I've found a workaround for now, just press Ctrl+Shift+S to display In-Call Status Bar which forces the screen to update.
Comment 20 José Luis 2018-02-22 20:41:35 UTC
Created attachment 26188 [details]
Screenshot of refresh issue

This is a screenshot of refreshing issue.
Comment 21 José Luis 2018-02-22 20:50:10 UTC
Comment on attachment 26188 [details]
Screenshot of refresh issue

I'm having this issue from some time ago. I have VS Enterprise and Xcode updated, latest stable Xamarin Forms and Win10 Fall Creators Update.

Some months ago it worked but one day it started to fail. I've also repaired simulator installation with no luck.
Comment 22 José Luis 2018-02-23 06:41:06 UTC
Ios simulator on mac is working OK, but remote simulator on Windows works bad, the image does not refresh, its not only related to application deployment, it happens always, even navigating through ios menus.
Comment 23 John Miller [MSFT] 2018-02-23 13:50:14 UTC
For those experiencing a refresh issue, please take a look at Comment 9 and provide the information requested in there. Thank you!
Comment 24 Alan McGovern 2018-02-23 14:13:44 UTC
BBL - the issue you're experiencing is occurring with Apple's iOS Simulator not Xamarin's Remoted Simulator. Your best option is to file a bug with Apple ( https://developer.apple.com/bug-reporting/ ) if you are certain the problem is not in your application. They should be able to advise you about issues with their Simulator.

Jose/Tomasz, if you can provide the information John asked we should be able to investigate further. Thanks!
Comment 25 José Luis 2018-02-23 19:10:08 UTC
Created attachment 26190 [details]
Information requested of refresh image issue

This is the information requested about refresh image issue on remote ios simulator. The zip contains the system information, logs, screenshots, video and project sample.