Bug 61030 - The missing file is ..\..\packages\Xamarin.Forms.\build\netstandard1.0\Xamarin.Forms.props.
Summary: The missing file is ..\..\packages\Xamarin.Forms.\build\netstanda...
Status: NEW
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: FirstRun ()
Version: 4.8.0 (15.5)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Nina
: 61031 ()
Depends on:
Reported: 2017-12-07 20:56 UTC by Dr. Beyond
Modified: 2018-02-02 20:04 UTC (History)
10 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 61030 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:

Description Dr. Beyond 2017-12-07 20:56:04 UTC
Since I upgrade visual studio 2017 for 15.5 release, I am getting the following error:

This project references NuGet package(s) that are missing on this computer. Use NuGet Package Restore to download them. The missing file is ..\..\packages\Xamarin.Forms.\build\netstandard1.0\Xamarin.Forms.props.
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2017-12-07 21:11:06 UTC
*** Bug 61031 has been marked as a duplicate of this bug. ***
Comment 2 Ton Snoei 2017-12-08 08:56:17 UTC
Same problem here. I downgraded to and older Xamarin.Forms version because of another bug in the latest Xamarin.Forms version. What a mess!!! This drives me crazy (sorry guys).
Comment 3 Ali 2017-12-09 08:52:17 UTC
It drives me crazy too!!
I'm using Visual Studio for mac poooooor nuget package manager to update one by one, I have 9 Class Libraries, I did it to all of them, After spending a lot of time, I faced with this error :(

(Sorry guys, We all need more attention)
Comment 4 Michel Moorlag 2017-12-15 07:59:32 UTC
Locally I can build without problem but on 2017-12-07 my VSTS Xamarin Forms Android builds started to fail with above error. How can I fix my vsts build?
Comment 5 Jason Smith [MSFT] 2017-12-20 20:18:09 UTC
Are you targeting .NET Standard 2.0? We don't support 1.0.
Comment 6 Michel Moorlag 2017-12-20 20:38:54 UTC
And 1.4? I am targeting .NET Standard 1.4.
Comment 7 Samantha Houts [MSFT] 2017-12-21 04:03:15 UTC
I have put together a test project targeting netstandard 1.4 in Visual Studio 2017 15.5.2. I can build with Xamarin.Forms versions 2.4.0 and version 2.5.0.

If this occurs locally for you, can you verify that the file is not actually there? On Windows, try checking C:\Users\<username>\.nuget\packages\Xamarin.Forms\\build\netstandard1.0. If it is not there, please delete the folder and try restoring packages again from Visual Studio.

If this occurs on VSTS for you, can you verify that your build is set to restore nuget packages and that you are not using a checked-in version of the packages folder that perhaps is missing the file?
Comment 8 Michel Moorlag 2017-12-21 07:54:58 UTC

Locally it build fine, the problem is in the VSTS build. I am sure I did not check in the packages in Git and I have a restore packages step before the build step.

I might have found the issue. When upgrading from XF to only the Android csproj file keeps two references to 91635. to be exact line:

<Import Project="..\..\packages\Xamarin.Forms.\build\netstandard1.0\Xamarin.Forms.props" Condition="Exists('..\..\packages\Xamarin.Forms.\build\netstandard1.0\Xamarin.Forms.props')" />

and line:

    <Error Condition="!Exists('..\..\packages\Xamarin.Forms.\build\netstandard1.0\Xamarin.Forms.props')" Text="$([System.String]::Format('$(ErrorText)', '..\..\packages\Xamarin.Forms.\build\netstandard1.0\Xamarin.Forms.props'))" />

I manually removed these lines from my Android csproj file and locally it builds and runs fine. Unfortunately I ran out of free VSTS minutes so I can't build on VSTS right now to test my hypothesis but I am quite sure it is related. Hope this helps.
Comment 9 Michel Moorlag 2017-12-21 08:01:11 UTC

Extra information. The VSTS build problem started when I upgraded from to Then I reverted the checkin and it was building fine again.
Comment 10 herman 2017-12-22 18:59:59 UTC

I've also had the problem with the upgrade from to My project file also referenced both versions.

The .props file is present in my packages folder in C:\users\ but there is no directory matching the 121934 package version in my solution directory while it does have a directory for 91635. The error indicates ..\..\packages\ in the path so I assume it is looking in my solution folder and not in the C:\users\ folder.
Comment 11 Michel Moorlag 2018-01-01 19:49:37 UTC
I can confirm that after removing the old X.F. refrences to in the .net standard csproj file the vsts build now builds fine as before as I already expected.
Comment 12 Raphael Augusto da Silva 2018-02-02 18:53:03 UTC
I am with this issue too. Any news about how to fix it?
Comment 13 Michel Moorlag 2018-02-02 20:04:42 UTC
@Raphael Augusto da Silva 

Open your android.csproj file with a text editor and remove all references to the old X.F. version (the one you are upgrading from). Clean and rebuild and you should be fine. Worked for me.