Bug 61029 - VSTS Build Agent Missing Xamarin.Android capability on macOS
Summary: VSTS Build Agent Missing Xamarin.Android capability on macOS
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 8.1 (15.5)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2017-12-07 18:44 UTC by Rafael Veronezi
Modified: 2017-12-12 21:47 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Agent Capabilities (696.04 KB, image/jpeg)
2017-12-07 18:44 UTC, Rafael Veronezi

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Rafael Veronezi 2017-12-07 18:44:50 UTC
Created attachment 25941 [details]
Agent Capabilities

After updating Visual Studio for Mac to version 7.3 (15.5) on macOS High Sierra 10.13.1, the build agent got broken for Android Builds. Trying to queue a new build shows the error:

"No registered agents found in the selected queue with the following capabilities: AndroidSDK, MSBuild, Xamarin.Android, JDK. Use a different queue."

Just checked out and the only missing capability is Xamarin.Android (as stated by the attachment). Tried re-installing Visual Studio for Mac, reconfiguring the Agent but still not working out.
Comment 1 Jon Douglas [MSFT] 2017-12-12 21:47:00 UTC
Hi Rafael,

I'm not so sure this is a Xamarin.Android issue but rather a VSTS issue? I would recommend reaching out for support here:


If there is anything specifically that we can look into on our end, feel free to open up a new bug or reopen this bug with further details.