Bug 61005 - Visual Studio becomes unresponsive when simulator starts
Summary: Visual Studio becomes unresponsive when simulator starts
Status: NEW
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.8.0 (15.5)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-12-06 17:20 UTC by Václav Dajbych
Modified: 2018-02-23 12:44 UTC (History)
7 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 61005 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:

Description Václav Dajbych 2017-12-06 17:20:01 UTC
After the Xamarin.iOS app builds and the simulator (iPhone 6s iOS 11.2) is going to launch Visual Studio 2017 becomes unresponsive.

The problem started after the Xcode update to version 9.2.

macOS 10.13.1
Visual Studio for Mac
Xcode 9.2
Xamarin Agent
Windows 10 version 1709 build 16299.64
Visual Studio 2017 version 15.5
Comment 1 Jimmy [MSFT] 2017-12-20 23:42:26 UTC
Visual Studio 2017 version 15.5 did not support Xcode 9.2 and there were issues related to the simulator due to this, but we have released an update to support it now. Are you still experiencing this issue with the latest version, 15.5.2?
Comment 2 Václav Dajbych 2017-12-21 14:15:53 UTC
Yes, I'm still experiencing this issue with Visual Studio 2017 15.5.2 and Visual Studio for Mac

When I launch the simulator it ends with fatal error. The second try launches it but the screen is black. Then I must close the simulator and launch it for the third time. Then it works.

I tried to reset its content and settings, but without any effect.
Comment 3 Václav Dajbych 2018-01-03 13:58:29 UTC
Application: MSBuild.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Threading.SemaphoreFullException
   at System.Threading.SemaphoreSlim.Release(Int32)
   at Xamarin.Messaging.Client.MessagingConnection.OnClientDisconnected(System.Object, System.Net.Mqtt.MqttEndpointDisconnected)
   at System.EventHandler`1[[System.__Canon, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089]].Invoke(System.Object, System.__Canon)
   at System.Net.Mqtt.Sdk.MqttClientImpl.Close(System.Net.Mqtt.DisconnectedReason, System.String)
   at System.Net.Mqtt.Sdk.MqttClientImpl.<ObservePackets>b__41_2()
   at System.Reactive.AnonymousSafeObserver`1[[System.__Canon, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089]].OnCompleted()
   at System.Reactive.ScheduledObserver`1[[System.__Canon, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089]].Dispatch(System.Reactive.Disposables.ICancelable)
   at System.Reactive.Concurrency.Scheduler+<>c.<ScheduleLongRunning>b__72_0(System.Action`1<System.Reactive.Disposables.ICancelable>, System.Reactive.Disposables.ICancelable)
   at System.Reactive.Concurrency.NewThreadScheduler+<>c__DisplayClass7_0`1[[System.__Canon, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089]].<ScheduleLongRunning>b__0()
   at System.Threading.ThreadHelper.ThreadStart_Context(System.Object)
   at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
   at System.Threading.ThreadHelper.ThreadStart()
Comment 4 Václav Dajbych 2018-01-11 13:28:02 UTC
Stack trace added.
Comment 5 Pavel Fedotovsky 2018-01-30 17:45:47 UTC
Had the same issue, solved by full rebuild - first manually cleaning bin/obj folders in all projects, then rebuild in VS
Comment 6 Václav Dajbych 2018-02-23 12:44:07 UTC
It helps but the error is back after a few debug/stop cycles. It is very annoying.