Bug 60807 - accessing MemoryMappedFiles threw exception on macOS
Summary: accessing MemoryMappedFiles threw exception on macOS
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Core ()
Version: 5.8 (2017-10)
Hardware: All Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2017-11-22 11:53 UTC by undead_man
Modified: 2018-03-13 16:34 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description undead_man 2017-11-22 11:53:37 UTC
some time ago i tried to use MemoryMappedFiles on MacOS.
Creating a new was no problem but open an existing threw a NotImplementedExpetion.
Last time the answer was it will be supported with Mono 5.4 - well now I tried it again (Mono but I run into same exception.


            var memoryMappedFile = MemoryMappedFile.CreateNew("test", 1024);
            var viewAccessor = memoryMappedFile.CreateViewAccessor();

            viewAccessor.Write(0, 42);

//Programm will throw exception at this point
            var memoryMappedFile2 = MemoryMappedFile.OpenExisting("test");
            var viewAccessor2 = memoryMappedFile2.CreateViewAccessor();

            var intValue = viewAccessor2.ReadChar(0);

I also Postet this at the Forum:
but ther is no reaction.

Will this bug be fixed?

Comment 1 Marek Safar 2018-03-13 16:34:51 UTC
Works as expected with Mono 5.8