Bug 60789 - Getting a string of "(null)" passed from entry box in Watch Windows, even though value is passed in.
Summary: Getting a string of "(null)" passed from entry box in Watch Windows, even tho...
Alias: None
Product: Live Player
Classification: Xamarin
Component: Mobile App iOS ()
Version: 1.2.X
Hardware: PC Windows
: --- minor
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-11-21 20:08 UTC by Tracy
Modified: 2017-11-29 01:01 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Sample project file (355.91 KB, application/x-zip-compressed)
2017-11-21 23:26 UTC, Tracy
Alpha signup (2.45 MB, image/jpeg)
2017-11-22 00:03 UTC, Tracy

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 60789 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:

Description Tracy 2017-11-21 20:08:27 UTC
We just tried to do the sample Xamarin forms app from this page.

The only thing we did differently was we used a shared project vs a PCL.
Everything works great when we pull up the UWP app or Android app in Xamarin Live Player.
The issue is when we use try to use the Live player on iOS.
When we click the button to Translate we get an exception.
When we stepped through debugging when we call Core.PhonewordTranslator.ToNumber(phoneNumberText.Text) it passes in the value of (null).
That's not NULL, its a string with a values of "(null)" rather than the default "1-855-XAMARIN".

I don't have a Mac handy to test a real deployment to see if it is an issue there as well.

Has anyone else experienced this kind of issue?
Comment 1 James Montemagno [MSFT] 2017-11-21 20:48:34 UTC
Hey there! can you attach your sample project.

For iOS can you validate the version your using under about/info?
Comment 2 Tracy 2017-11-21 23:20:35 UTC
I am attaching the project.
On Anroid I am on 1.2.80 but on iOS I have the latest on the app store 1.0.252 i think.

Sorry for the large size.
Comment 3 Tracy 2017-11-21 23:26:17 UTC
Created attachment 25782 [details]
Sample project file

I had to remove all the nuget packages and obj folders to get it small enough to post.
Comment 4 James Montemagno [MSFT] 2017-11-21 23:34:48 UTC
Ahhh. Yeah this should be solved if you sign up for our Fast Ring version: https://xamarinhq.wufoo.com/forms/live-player-alpha-program-agreement/

This will get you the latest and greatest.
Comment 5 Tracy 2017-11-22 00:03:49 UTC
Created attachment 25783 [details]
Alpha signup

I signed up earlier today but it said it will take up to 7 days.
Is there anything you can do?

By the way we have meet a few times at both Xamarin Evolve and last Octobers Dev Intersection.

Keep up the good work over there.
Comment 6 James Montemagno [MSFT] 2017-11-22 18:42:37 UTC
I will process them today :)
Comment 7 James Montemagno [MSFT] 2017-11-22 20:38:53 UTC
Actually can you sign up here: http://aka.ms/liveplayeralpha

It now has instant access :)

Oh that is awesome! glad to run into you again :)

Will close for now since the new one fixes this.
Comment 8 Tracy 2017-11-23 01:31:35 UTC
I was able to get the latest version from Test flight and I still get the same error where is passes the string of "(null)".

Not sure what the issue is.
Can you please check the solution I uploaded?

Comment 9 James Montemagno [MSFT] 2017-11-23 06:32:43 UTC
hmmmm, will test out the uploaded version :) thanks for the feedback!
Comment 10 James Montemagno [MSFT] 2017-11-29 00:52:31 UTC
Tracy, so it looks like if you add a break point to:
Line 22 in LoginPage.xaml.cs you will see that the actual number is being passed in.

However you are right that it "says" it is null actually inside the method even though it is not. Even though it says null the value is still there and the method executes correctly.

I will mark this as confirmed, but just some weird locals/watch coming up.