Bug 60562 - Conflicting values for resource 'Files/Xamarin.Forms.Platform.UAP/TabbedPageStyle.xbf' (UWP)
Summary: Conflicting values for resource 'Files/Xamarin.Forms.Platform.UAP/TabbedPageS...
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-11-08 00:39 UTC by Melbourne Developer
Modified: 2017-12-15 18:56 UTC (History)
4 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 60562 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Melbourne Developer 2017-11-08 00:39:07 UTC
I'm trying to debug the Xamarin Forms library through my sample app using UWP. The point is to find an issue that may be under the hood of Xamarin Forms. However, when I try to compile my app, I get two compilation errors:

Severity	Code	Description	Project	File	Line	Suppression State
Error		Conflicting values for resource 'Files/Xamarin.Forms.Platform.UAP/TabbedPageStyle.xbf'	Adapt.PresentationSamples.UWP	C:\GitRepos\Adapt.Presentation\Adapt.PresentationSamples.UWP\MakePRI		
Error		Processing Resources failed with error: Duplicate Entry.	Adapt.PresentationSamples.UWP	C:\GitRepos\Adapt.Presentation\Adapt.PresentationSamples.UWP\MakePri		

To repo the problem:

-Clone this repo: https://github.com/MelbourneDeveloper/Adapt.Presentation.git in to C:\GitRepos\Adapt.Presentation
-Switch to the branch AdaptTreeViewItemProviderXFDebug
-Clone the Xamarin Forms repo in to C:\GitRepos\Xamarin.Forms (you can just cut and paste the folder there)
-Open the solution Adapt.Presentation.sln.
-*Optionally* unload all non-UWP, non-.NET Standard projects
-Attempt to build
-You will see the above error message.

I'm guessing that this problem has something to do with C:\GitRepos\Xamarin.Forms\Xamarin.Forms.Platform.UAP\TabbedPageStyle.xaml
Comment 1 Paul DiPietro [MSFT] 2017-11-08 19:21:11 UTC
I can see this occurring on a cursory lookover and will leave it as confirmed until further investigation. I'm unsure if there's potentially a version conflict somewhere or not, but it may be worth looking into in the meantime to see if it doesn't aid the situation in any way.
Comment 2 Melbourne Developer 2017-11-09 02:43:08 UTC
Thanks. What do you mean by a version conflict? I'm using the code directory from the Github repo. I'm not referencing any other assemblies that I know about.
Comment 3 Melbourne Developer 2017-11-09 03:03:40 UTC
I think this might have been a bit of a false alarm...

A couple of the projects were still referencing the Xamarin.Forms NuGet package.

But, now that I've removed those, nothing compiles. I can't reference the compiled Xamarin.Forms.Core library because visual studio says that only other PCL libraries can be references.

Is there a tutorial somewhere on how to debug the Xamarin.Forms library? A sample app?

I really need to look at the code see what is going on.
Comment 4 FieldstrikeMobile 2017-11-13 14:26:18 UTC
I am also seeing this error.

Could have been introduced when switching over to .Net Standard libraries from PCL.

I cannot see anywhere where there would be conflicting versions.

My project references .Net Standard 1.4
Comment 5 Melbourne Developer 2017-11-13 22:23:41 UTC
Just check to make sure you are not referencing any DLLs from the Xamarin.Forms libraries that may be of different versions.
Comment 6 FieldstrikeMobile 2017-11-16 15:14:53 UTC
@MelbourneDeveloper I have checked all my projects and all are referencing the same version.
There is only 1 version in my packages folder.

Have you solved this error in your project?

Mine builds successfully in release but not in debug
Comment 7 Melbourne Developer 2017-11-16 22:29:13 UTC
Yes. I don't have a problem anymore. I was still never able to debug Xamarin.Forms, but that is a separate issue.
Comment 8 Melbourne Developer 2017-11-16 22:30:00 UTC
Maybe you should try doing a full clean on your folder, deleting all the Xamarin temp files out of the user folder, upgrading all the NuGet packages and rebuilding.
Comment 9 FieldstrikeMobile 2017-11-17 08:56:33 UTC
@Melbourne Developer

What do you mean by "deleting all the Xamarin temp files out of the user folder"

I will try clean everything and find this issue its a real blocker as it puts my UWP project out of action
Comment 10 FieldstrikeMobile 2017-11-17 09:05:27 UTC
I deleted packages folder
deleted every bin/ obj folder in every csproj which was part of my solution
Built the project and it worked.

Really strange, never seen anything like that before

(P.S. a standard VS "Clean" and "Rebuild" didnt work)
Comment 11 Melbourne Developer 2017-12-15 18:54:33 UTC
I'm getting the problem again. I've tried doing a full Git clean, and deleting all the Xamarin data in my user folder. I still can't compile the UWP app.
Comment 12 Melbourne Developer 2017-12-15 18:55:19 UTC
The app used to compile and run. Now, randomly. It doesn't
Comment 13 Melbourne Developer 2017-12-15 18:56:43 UTC
On some computers it compiles. On others it doesn't.