Bug 60520 - dllmap is failing on iOS
Summary: dllmap is failing on iOS
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: XI 11.4 (d15-5)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Rolf Bjarne Kvinge [MSFT]
Depends on:
Reported: 2017-11-03 21:00 UTC by James Clancey
Modified: 2017-11-06 14:22 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description James Clancey 2017-11-03 21:00:46 UTC
dllmaps are not working when I have multiple libraries I have tried with both app.config and ManagedBass.Fx.dll.config

this is broken on both simulator and device

TestCase: https://github.com/Clancey/gMusic/tree/dllmap
Clone and run the setup.sh

=== Visual Studio Community 2017 for Mac ===

Version 7.2.2 (build 7)
Installation UUID: bc6b1fbe-d3ff-45ec-a1ae-d8123578f97a
	Mono (2017-06/1f4613aa1ac) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 504010006

=== NuGet ===


=== .NET Core ===

Runtime: /usr/local/share/dotnet/dotnet
Runtime Versions:
SDK: /usr/local/share/dotnet/sdk/2.0.2/Sdks
SDK Versions:
MSBuild SDKs: /Library/Frameworks/Mono.framework/Versions/5.4.1/lib/mono/msbuild/15.0/bin/Sdks

=== Xamarin.Profiler ===

Version: 1.5.6
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Xamarin.Android ===

Version: (Visual Studio Community)
Android SDK: /Users/clancey/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)
		7.0   (API level 24)
		7.1   (API level 25)
		8.0   (API level 26)

SDK Tools Version: 26.0.2
SDK Platform Tools Version: 25.0.6
SDK Build Tools Version: 25.0.2

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:

=== Apple Developer Tools ===

Xcode 9.0.1 (13249)
Build 9A1004

=== Xamarin.iOS ===

Version: (Visual Studio Community)
Hash: 12e80e01
Branch: d15-4-xi
Build date: 2017-10-13 12:03:42-0400

=== Xamarin Inspector ===

Version: 1.3.2
Hash: 461f09a
Branch: 1.3-release
Build date: Tue, 03 Oct 2017 18:26:57 GMT
Client compatibility: 1

=== Xamarin.Mac ===

Version: (Visual Studio Community)

=== Build Information ===

Release ID: 702020007
Git revision: 2236098c68f51eeb447cb947a87371d1e84f6213
Build date: 2017-10-23 11:43:05-04
Xamarin addins: eaa605cf97f25ce184949f32c712b465ca96f665
Build lane: monodevelop-lion-d15-4

=== Operating System ===

Mac OS X 10.12.6
Darwin 16.7.0 Darwin Kernel Version 16.7.0
    Wed Oct  4 00:17:00 PDT 2017
    root:xnu-3789.71.6~1/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

MicroFramework 1.0.1
Internet of Things (IoT) development (Preview) 7.1
Comment 1 Rolf Bjarne Kvinge [MSFT] 2017-11-03 21:24:37 UTC
I’ll have a look
Comment 2 Vincent Dondain [MSFT] 2017-11-03 22:21:20 UTC
@clancey can you explain exactly how to reproduce the issue?

I downloaded your project, ran Setup.sh and could build and run the app just fine. What else do I need to do?
Comment 3 James Clancey 2017-11-03 22:24:06 UTC
The app runs fine, I have proper error handling! However this line crashes.


Should auto hit, if not just add that same line to the app delegates finished launching so it crashes for real.
Comment 4 Rolf Bjarne Kvinge [MSFT] 2017-11-06 14:21:32 UTC
Renaming the app.config to ManagedBass.Fx.dll.config and setting the build action to BundleResource worked for me.

Can you try that too?
Comment 5 Rolf Bjarne Kvinge [MSFT] 2017-11-06 14:22:12 UTC