Bug 60394 - error CS1061: 'InterfaceImplementation' does not contain a definition for 'Resolve' and no extension method 'Resolve' accepting a first argument of type 'InterfaceImplementation' could be found
Summary: error CS1061: 'InterfaceImplementation' does not contain a definition for 'Re...
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Sebastien Pouliot
Depends on:
Reported: 2017-10-26 15:06 UTC by Vincent Dondain [MSFT]
Modified: 2017-11-03 01:27 UTC (History)
4 users (show)

Is this bug a regression?: Yes
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Vincent Dondain [MSFT] 2017-10-26 15:06:46 UTC
With Mono JIT compiler version (2017-10/7e1e1886dae Tue Oct 24 16:10:25 EDT 2017) we're getting:

`ObjCInterfaceCheck.cs(117,44): error CS1061: 'InterfaceImplementation' does not contain a definition for 'Resolve' and no extension method 'Resolve' accepting a first argument of type 'InterfaceImplementation' could be found (are you missing a using directive or an assembly reference?) [/Users/vidondai/Documents/xi-xcode9/xamarin-macios/tests/xtro-sharpie/xtro-sharpie.csproj]`

This is happening in https://github.com/xamarin/xamarin-macios/blob/master/tests/xtro-sharpie/ObjCInterfaceCheck.cs#L117.

To repro just do a `make` in `xamarin-macios/tests/xtro-sharpie`.
Comment 1 Sebastien Pouliot 2017-10-27 12:31:14 UTC
That version of mono has a newer Cecil (with a breaking change). It's already fixed in the mono-2017-10 branch


Use the previous mono (5.6) until it's merged (in master). You might have to anyway to work on older branches.
Comment 2 Vincent Dondain [MSFT] 2017-10-27 18:30:03 UTC
> It's already fixed in the mono-2017-10 branch

@sebasiten, I tried the `xamarin-macios/mono-2017-10` branch yesterday (forgot to comment). Re-tried today and it's not fixed there: https://github.com/xamarin/xamarin-macios/blob/mono-2017-10/tests/xtro-sharpie/ObjCInterfaceCheck.cs#L117
Comment 3 Vincent Dondain [MSFT] 2017-10-27 18:31:51 UTC
I butchered your name Sebastien, I apologize (:
Comment 4 Sebastien Pouliot 2017-11-02 19:00:03 UTC
Comment 5 Sebastien Pouliot 2017-11-02 19:20:31 UTC
First (GitHub generated) PR was closed since it showed other commits in its UI (but not in the diff).

Comment 6 Sebastien Pouliot 2017-11-03 01:27:33 UTC
Merged in master with https://github.com/xamarin/xamarin-macios/commit/b8294246ddf32c021a6c6884cd97a54b4e793990