Bug 6014 - Remove from source control removes all files
Summary: Remove from source control removes all files
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: Trunk
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: Marius Ungureanu
: 12436 ()
Depends on:
Reported: 2012-07-06 13:35 UTC by Alan McGovern
Modified: 2013-07-16 05:29 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alan McGovern 2012-07-06 13:35:13 UTC
If a project is under git version control and you choose to remove it from version control, all the local files are deleted. This should not happen. Only the .git directory containing the repository information should be deleted.
Comment 1 Chris 2012-09-25 13:04:24 UTC
I see that this is still not correct at v, more than 2 months after reporting it. I just lost some work again - i even zipped the files before removing from source control (because the original 'add to source control' hadn't worked correctly) but the zip file was deleted as well!
When will this be fixed?
Comment 2 Marius Ungureanu 2013-07-12 11:36:24 UTC
This has been fixed and will be included in a future release.
Comment 3 Lluis Sanchez 2013-07-16 05:29:59 UTC
*** Bug 12436 has been marked as a duplicate of this bug. ***