Bug 60053 - Unable to use Microsoft.ProjectOxford.Face & Microsoft.ProjectOxford.Emotion plug-ins in Xamarin.Forms project
Summary: Unable to use Microsoft.ProjectOxford.Face & Microsoft.ProjectOxford.Emotion ...
Status: RESOLVED DUPLICATE of bug 60075
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-10-09 10:13 UTC by Nidhi Sood
Modified: 2017-10-10 09:40 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Nidhi Sood 2017-10-09 10:13:05 UTC
From past 2-3 weeks I've been trying to implement Microsoft's cognitive services for face and emotion detection. I've tried using the plug-ins provided by Xamarin to do the job. But unfortunately I've not succeeded yet. Because, whatever project I create, be it Xamarin's Native android or iOS or Xamarin.Forms' shared or PCL project, both theses packages never worked in any of them. Though, I was able to  use the Vision service once in my sample native project for Xamarin, but that too is crashing now and I've no idea why? It was working fine previously, but has stopped now throwing the following exception:

critical: Stacktrace:

2017-10-06 18:27:20.281 GitCommitDemo.iOS[21184:1477804] critical: 
Native stacktrace:

2017-10-06 18:27:20.282 GitCommitDemo.iOS[21184:1477804] critical: 	0   GitCommitDemo.iOS                   0x0017235f mono_handle_native_crash + 239
2017-10-06 18:27:20.283 GitCommitDemo.iOS[21184:1477804] critical: 	1   GitCommitDemo.iOS                   0x0017fe45 mono_sigsegv_signal_handler + 293
2017-10-06 18:27:20.283 GitCommitDemo.iOS[21184:1477804] critical: 	2   libsystem_platform.dylib            0x05873e5b _sigtramp + 43
2017-10-06 18:27:20.283 GitCommitDemo.iOS[21184:1477804] critical: 	3   ???                                 0xffffffff 0x0 + 4294967295
2017-10-06 18:27:20.284 GitCommitDemo.iOS[21184:1477804] critical: 	4   GitCommitDemo.iOS                   0x002dabeb finish_gray_stack + 123
2017-10-06 18:27:20.284 GitCommitDemo.iOS[21184:1477804] critical: 	5   GitCommitDemo.iOS                   0x002db493 major_finish_collection + 115
2017-10-06 18:27:20.284 GitCommitDemo.iOS[21184:1477804] critical: 	6   GitCommitDemo.iOS                   0x002d7221 major_do_collection + 145
2017-10-06 18:27:20.284 GitCommitDemo.iOS[21184:1477804] critical: 	7   GitCommitDemo.iOS                   0x002d65f1 sgen_perform_collection + 737
2017-10-06 18:27:20.285 GitCommitDemo.iOS[21184:1477804] critical: 	8   GitCommitDemo.iOS                   0x002d8144 sgen_gc_collect + 52
2017-10-06 18:27:20.285 GitCommitDemo.iOS[21184:1477804] critical: 	9   GitCommitDemo.iOS                   0x003349e2 _ZL7pump_gcPv + 66
2017-10-06 18:27:20.285 GitCommitDemo.iOS[21184:1477804] critical: 	10  libsystem_pthread.dylib             0x05884047 _pthread_body + 184
2017-10-06 18:27:20.285 GitCommitDemo.iOS[21184:1477804] critical: 	11  libsystem_pthread.dylib             0x05883f8f _pthread_body + 0
2017-10-06 18:27:20.286 GitCommitDemo.iOS[21184:1477804] critical: 	12  libsystem_pthread.dylib             0x0588384a thread_start + 34
2017-10-06 18:27:20.286 GitCommitDemo.iOS[21184:1477804] critical: 
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.

I'm now trying to implement the Face detection service using Microsoft.ProjectOxford.Face plug-in in Xamarin.Forms PCL project, but it never debugs and raises different errors every time. Like, if I use FaceAttributeType for defining the face attributes in the api it gives the following error:

/Volumes/Data/_Xamarin Workspace /Practice/FaceDetectionPCL/iOS/MTOUCH: Error MT2002: Failed to resolve "Microsoft.ProjectOxford.Face.FaceAttributeType" reference from "Microsoft.ProjectOxford.Face, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" (MT2002) (FaceDetectionPCL.iOS)

And if I remove all the FaceAttributeType code, then it start raising this error:

/Volumes/Data/_Xamarin Workspace /Practice/FaceDetectionPCL/iOS/MTOUCH: Error MT2002: Failed to resolve "Microsoft.ProjectOxford.Face.Contract.Face" reference from "Microsoft.ProjectOxford.Face, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" (MT2002) (FaceDetectionPCL.iOS).

This happens every time I try to debug my code. I can't understand what is the issue. I've followed a lot of blogs to implement this, but I don't know where am I getting wrong. If anyone could help or give me some hint to resolve this, it will be really appreciable. Thanks in advance!!
Comment 1 Paul DiPietro [MSFT] 2017-10-09 14:19:36 UTC
If this is not working in non-Forms projects then it's likely not a Forms-specific issue. A reproduction might help and it could perhaps be reassigned to the Mono team for further investigation, from just looking at the error.
Comment 2 Nidhi Sood 2017-10-10 05:09:17 UTC
Thanks for your fast response @paul. I'll try reporting to the Mono team. Hope, they fix it or at-least provide some work around. But one thing I'm really curious about, Isn't there any body who have implemented the face detection in Xamarin yet? If not, then nobody ever reported this issue to the their team before?
Comment 3 Matt Ward 2017-10-10 08:14:13 UTC
*** Bug 60075 has been marked as a duplicate of this bug. ***
Comment 4 Matt Ward 2017-10-10 09:40:56 UTC
Marking as duplicate.

*** This bug has been marked as a duplicate of bug 60075 ***