Bug 60021 - [MacOS] After PushAsync the page remains empty, but elements react on taps
Summary: [MacOS] After PushAsync the page remains empty, but elements react on taps
Alias: None
Product: Forms
Classification: Xamarin
Component: Mac ()
Version: 2.4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Rui Marinho
Depends on:
Reported: 2017-10-06 13:57 UTC by Michael Rumpler
Modified: 2017-10-13 12:28 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Repro project (663.08 KB, application/x-zip-compressed)
2017-10-06 13:57 UTC, Michael Rumpler

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 60021 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Michael Rumpler 2017-10-06 13:57:02 UTC
Created attachment 25169 [details]
Repro project

When I use a NavigationPage as MainPage and try to push another page, then the page is not displayed. But if I know where navigation elements are, I can still tap them and the tap handler is executed.

The sample app displays only a ListView with 5 elements. On tapping of any of the elements, a new page is pushed. Every page displays a new Title. I do see the first page with the ListView when I start the app on the Mac, but when I tap any element, the next page is not shown. The Title is changed accordingly, but the content of the page is white. I can still tap somewhere on the next list elements and it proceeds to the next page. Through the changes of the Title I see that the navigation still does something, but the page remains empty. When I go back to the first page, then I do see that page again.

This works as expected on UWP and iOS. I also left the Android project in. It should work there too, but I didn't test it.

I used XF
Comment 1 Michael Rumpler 2017-10-13 12:28:18 UTC
The problem seems to be related to the Xamarin.Mac version.

When I filed this bug, I was using VS for Mac (Preview) 7.2 build 634 and Xamarin.Mac Now I updated to VS 7.3 build 692 and Xamarin.Mac I'm on the alpha channel.

In one of my apps it works now - without changing anything in the source/dependencies. But the attached repro app still doesn't work.