Bug 59983 - [Willow -VS 2017][VS-Val 26929.9000][Emulator Config changes] -ARM emulator [Android_ARM_Nougat] from the Android 25 Bump is NOT booting up
Summary: [Willow -VS 2017][VS-Val 26929.9000][Emulator Config changes] -ARM emulator [...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: 15.5
Assignee: Nina
Depends on:
Reported: 2017-10-05 13:31 UTC by Gaurav Ganorkar
Modified: 2017-11-13 13:10 UTC (History)
6 users (show)

Tags: Globallogic
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Gaurav Ganorkar 2017-10-05 13:31:27 UTC
-When installed build from  \\cpvsbuild\drops\VS-Val\d15svc\products\26929.9000.vyedin.170929.061626 and Tried to start the Android 7.1 ARM emulator , We observed that it's not booting up at all. Tried this on clean machine

Trello card link

Build info
-Microsoft Visual Studio Enterprise 2017 d15svc
Version 15.4.0 Preview 4.0 [26929.9000.merge]
Microsoft .NET Framework
Version 4.7.02053

Installed Version: Enterprise

Xamarin (4af324312)
Xamarin.Android SDK (HEAD/872694031)
Xamarin.iOS and Xamarin.Mac SDK (9a9f054)

Full Build info

Steps to Reproduce
1-Install the build from the above given location [\\cpvsbuild\drops\VS-Val\d15svc\products\26929.9000.vyedin.170929.061626]
2-After installation , Create an Android Project
3-Select Emulator as "Android_ARM_Nougat" and Deploy the application

-Android Nougat ARM emulator is not booting up at all. Black screen is observed
-Also tried  Wipe user data , but still ARM emulator was not booting up

-Emulator should boot up and Application should get deploy successfully on ARM nougat emulator

Screencast link

Note-i have waited around 5 to 10 minutes to Boot Nougat ARM emulator but Black screen was observed overall
Comment 1 Pierce Boggan [MSFT] 2017-10-05 15:45:55 UTC
Spoke with Nina, and she will be removing the ARM emulator from the Visual Studio install.
Comment 3 Pierce Boggan [MSFT] 2017-11-09 03:05:06 UTC
This was approved by ShipRoom today as a 15.5 Preview 4 candidate fix through Work Item #520740 (https://devdiv.visualstudio.com/DevDiv/XamarinVS/_workitems/edit/520740) and merged this evening via https://devdiv.visualstudio.com/DevDiv/_git/VS/pullrequest/88471?_a=overview).

Marking this ticket as RESOLVED-FIXED.
Comment 4 Gaurav Ganorkar 2017-11-13 13:10:20 UTC
This bug is now invalid as We have Removed the arm emulator 

Trello card link - https://trello.com/c/xgNFaWcv/47-removing-arm-emulator

Also have introduce new x86 emulator (Nougat) which can be booted in accelerated as well as in Unaccelerated mode. This condition have been tested.I have installed the latest build from d15rel build number 15.5.0-pre.4.0+27110.0.d15rel

Build info
Microsoft Visual Studio Enterprise 2017 d15rel
Version 15.5.0 Preview 4.0 [27110.0.d15rel]
Microsoft .NET Framework
Version 4.7.02046

Installed Version: Enterprise

Xamarin (a773aca)
Xamarin Designer   4.8.152 (5e0da2967)
Xamarin.Android SDK (HEAD/f65f87747)
Xamarin.iOS and Xamarin.Mac SDK (c4240f3)

Build info Gist - https://gist.github.com/ganorkargaurav/0e0b18ed21f2f180bd6ae34051889d67
So marking this bug as Verified FIXED