Bug 59714 - AndroidComponentInfoSystemImage.Abi reads Default for an x86 image
Summary: AndroidComponentInfoSystemImage.Abi reads Default for an x86 image
Alias: None
Product: Android
Classification: Xamarin
Component: SDK Manager ()
Version: 8.0 (15.4)
Hardware: PC All
: High major
Target Milestone: 15.5
Assignee: Sergey Shakhnazarov
Depends on:
Reported: 2017-09-25 07:19 UTC by Sergey Shakhnazarov
Modified: 2017-11-24 12:04 UTC (History)
7 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Sergey Shakhnazarov 2017-09-25 07:19:55 UTC
We are setting AndroidSystemImageAbi.Default to x86, so `AndroidSystemImageAbi.X86.ToString()` gives `Default` instead of `X86` (this value was being written to the installed image' package.xml, and avdmanager failed to map it to abi).
This will be hidden by https://github.com/xamarin/android-sdk-installer/pull/42 in terms of new images installation although the Abi property will be incorrect anyway if used in the code in any other place.
Comment 2 Sarang Kanchalwar 2017-11-20 11:28:31 UTC
I Tried to verify the bug on the latest build from d15.5 Preview 4( 15.5.0-pre.4.0+27107.1.d15rel)

I am still seeing the issue when i tried to run the avd command (build tools v26.1.1).

C:\Program Files (x86)\Android\android-sdk\tools\bin>avdmanager.bat "create" "avd" "-n" "test" "-k" "system-images;android-25;google_apis;x86" "--tag" "google_apis" "--abi" "x86" "-d" "Nexus 5X" "--sdcard" "100M"

I am seeing this error given in the gist 
- https://gist.github.com/ksarang2009/04cdf68970e916a3c50aa30f0f210d7c

Getting : Warning: cvc-type.3.1.3: The value 'default' of element 'abi' is not valid
Error: Invalid --abi x86 for the selected package.

Hence reopening this issue

Build info 
-Xamarin (22893da50)
Xamarin Designer   4.8.143 (14e3edba0)
Xamarin.Android SDK (HEAD/f65f87747)
Xamarin.iOS and Xamarin.Mac SDK (c4240f3)
Comment 4 Gaurav Ganorkar 2017-11-24 12:04:19 UTC
Issue is FIXED

For Windows

Verified it on - d15.5 Preview 4 build

Xamarin SDK manager build - https://bosstoragemirror.blob.core.windows.net/wrench/sdk-manager-windows-d15-5-daserge-fix-59714/52/5220d7ace3eff563cf2cf1de7d82358683a3238e/Xamarin.AndroidSDKManager.msi

SDK manager version -

ScreenCast link - http://www.screencast.com/t/jtrKlxlCFy8V

For MacOS

Build taken From

VSfM Version -

Screencast link- http://www.screencast.com/t/LK4TlPyT

I also Tried with changing the package.xml <abi> to Default and Later running the SDK manager. The broken images gets Fix for both the Windows and MacOS.

Hence marking this issue as Fixed and Moving this card to QA accepted

Note- Until and Unless user opens the SDK manager , the system images with wrong ABI types doesn't fix itself. After user opens the SDK manager the FIX applies.