Bug 59610 - Unhandled exception while paging MasterDetailPage on x number of pages
Summary: Unhandled exception while paging MasterDetailPage on x number of pages
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-09-20 15:52 UTC by david.staite
Modified: 2017-10-09 22:17 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description david.staite 2017-09-20 15:52:36 UTC

I have a master detail page in my project, 

It seems that every x number of times I change the page visual studio responds with an unhandled exception. This seems to only affect android (both on the emulator and my Galaxy S6 Edge Plus).

It doesn't depend on the page I choose, I can select the same page or a variety of pages x number of times and replicate the issue.

At one point I tried reassigning the Master page which caused the app to crash every 4 pages!

At the minute it seems around 10-15.

I was on XAMARIN.FORMS, tried updating to and same issue.

Some of my code:

Comment 1 Paul DiPietro [MSFT] 2017-09-20 16:01:15 UTC
If you have the time, could you please attach a complete reproduction project to this ticket so we have everything in one place? I would also suggest testing against the latest 2.4.0-pre3 release (there are well over 150 fixes between it and 2.3.4) to see if the issue still occurs. It would be much appreciated. Thanks!
Comment 2 david.staite 2017-09-21 09:02:01 UTC
I tested 2.4.0-pre3 which seemed to have fixed the issue cheers!

Is there an eta on the official release of it?

Comment 3 Paul DiPietro [MSFT] 2017-10-09 22:17:51 UTC
Marking as resolved as 2.4.0 is now stable.