Bug 59074 - Cannot download alpha channel for the MAC build machine any longer
Summary: Cannot download alpha channel for the MAC build machine any longer
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 10.5.99 (Xcode 8.3 previews)
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2017-08-27 16:48 UTC by Stephen Marcus
Modified: 2017-08-29 03:15 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Stephen Marcus 2017-08-27 16:48:24 UTC
I have the new Visual Studio for Windows 10, version 15.3, and so am forced into "alpha" mode. I have to use the alpha channel for everything now.

Because of that,  went to my MAC build machine and tried t download the alpha channel version of Xamarin.IOS there. It showed many valid items to download. Two of them succeeded.  Six did *not* and will not download.  They just show as "FAILED".  I have tried over a dozen times to download with no success.

Is there any reason that the alpha channel for Xamarin.IS on the MAC is not functioning?  I can't do development in .NET Standard 2.0 without this update.  The versions don't match between the MAC build machine and my Windows machine. 

The version now failing to download is
Comment 1 Tim Miller 2017-08-28 20:07:15 UTC
Hey Stephen

There was an error in the Updater XML that was causing the wrong hashes to be set for the files, causing the IDE to give you those error messages. This was fixed, but the IDE is still checking against the old updater files.

To fix this, you should be able to set the channel in the updater to "Beta" or "Stable," then switch it back to "Alpha" to force it to check for new XML. You might need to restart Visual Studio for Mac for this to take effect.

Once you do, it should download successfully.
Comment 2 Stephen Marcus 2017-08-29 03:15:29 UTC
Hi, that worked thanks!

What about creating a Xamarin.Forms app using this new platform?  I still only see "shared" and "pcl" as options, and cannot seem to get around the limitation through trickery like creating project.json, etc.

Was .NET Standard released for ASP.Net folks only, or for all of us -- ?