Bug 58961 - CentOS 7 issues upgrading to mono 5.2 with gtk-sharp2
Summary: CentOS 7 issues upgrading to mono 5.2 with gtk-sharp2
Alias: None
Product: Installers
Classification: Mono
Component: Linux packages ()
Version: 5.2.0 (2017-04)
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Jo Shields
Depends on:
Reported: 2017-08-22 20:53 UTC by Mark Final
Modified: 2017-08-24 09:18 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Mark Final 2017-08-22 20:53:51 UTC

I have tried to upgrade mono from on CentOS 7, installed from http://www.mono-project.com/download/#download-lin-centos, to

However, this error has resulted:

--> Finished Dependency Resolution
Error: Package: gtk-sharp2-devel-2.12.26-3.el7.x86_64 (@epel)
           Requires: gtk-sharp2 = 2.12.26-3.el7
           Removing: gtk-sharp2-2.12.26-3.el7.x86_64 (@epel)
               gtk-sharp2 = 2.12.26-3.el7
           Updated By: gtk-sharp2-2.12.43-0.xamarin.5.epel7.x86_64 (download.mono-project.com_repo_centos7_)
               gtk-sharp2 = 2.12.43-0.xamarin.5.epel7
           Available: gtk-sharp2-2.12.26-0.x86_64 (download.mono-project.com_repo_centos7_)
               gtk-sharp2 = 2.12.26-0
 You could try using --skip-broken to work around the problem

I'm not exactly sure what it's stating the problem is here.

Any tips greatly appreciated.
Comment 1 Jo Shields 2017-08-22 21:16:15 UTC
OK. I implemented a fix for this incorrectly a long time ago. I think I've fixed it properly now, but I can't publish a fixed build until I fix installability of Mono 5.4 alpha, which it turns out is also broken. Should be fine later this week.
Comment 2 Mark Final 2017-08-22 21:30:35 UTC
Thanks Jo.

If you ping me a message on here when you've published it, I will give it a whirl.

I appreciate your time.
Comment 3 Jo Shields 2017-08-23 20:24:42 UTC

As a little background: for a super long time, Red Hat refused to publish Mono packages, so when I started at Xamarin, I took the state of the art from openSUSE & worked from there. Eventually, RHEL added Mono packages.

One area they differ is in Gtk# - SUSE basically ships everything in one package, and RHEL (correctly) splits the development-related files (.pc files) into a -devel package. So gtk-sharp2-devel existed in RHEL, but not in SUSE (or SUSE-derived packages like ours).

I've now added a dummy empty gtk-sharp2-devel package, whilst retaining the SUSE package structure, which means the dependencies in both SUSE and RHEL work.

The failures stemmed from any gtk-sharp2-devel dependency trying to use RHEL's package, but there being files in both RHEL's gtk-sharp2-devel and Mono's gtk-sharp2, hence the conflict.
Comment 4 Mark Final 2017-08-24 09:18:17 UTC
Thanks for the explanation, Jo.

Also happy to report, I now have a mono 5.2 install on my CentOS 7 box :)