Bug 58745 - VS2017 hangs on opening solution
Summary: VS2017 hangs on opening solution
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 4.5.0 (15.2)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2017-08-14 10:23 UTC by DmytroBondarenko
Modified: 2017-09-11 17:54 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

zip with logs and screenshots (770.40 KB, application/x-zip-compressed)
2017-08-14 10:23 UTC, DmytroBondarenko

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description DmytroBondarenko 2017-08-14 10:23:36 UTC
Created attachment 24165 [details]
zip with logs and screenshots

I had similar problem with VS2015 on my previous OS installation, I also had there VS2017 installed. But, when I opened the solution from VS2015 'latest solutions' it worked in 99%, and failed always if I opened the solution from .sln file. 

Yesterday I reinstalled my OS and installed only vs2017 pro, also I have Resharper. 

I can't open any project with xamarin. VS hangs on opening solution. 

I tried to debug that VS instance, here is all logs and links to the screenshots.
https://1drv.ms/f/s!AhNFife_tyLSpNNiZ_E4Ou6Oexc3Mw (also I added it as attachment)

Also, there is no problem with the project created from default template, at first time, right after the project was created, but VS hangs trying to open it.
Comment 2 Jimmy [MSFT] 2017-08-14 17:15:47 UTC
I have experienced this before with VS2017 15.2 but the same solution would load fine with VS2017 15.3. Can you update to the VS2017 15.3 build that was released today and let us know if this still occurs with the newer version? Thanks!
Comment 3 DmytroBondarenko 2017-08-14 18:35:46 UTC
Awesome :) Yep, just updated, both solutions works, but I'm going to make more test before switching back from osx's VS.
Comment 4 Pierce Boggan [MSFT] 2017-09-11 17:54:20 UTC
Given that this bug is no longer reproducible with Visual Studio 2017 version 15.3.*, I am marking this bug as RESOLVED ANSWERED. Thanks again for the bug report. :)