Bug 58656 - Adding System.Reactive NuGet package to "Mono" profile does not reference the assembly
Summary: Adding System.Reactive NuGet package to "Mono" profile does not reference the...
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Client: Cross Platform (Shared Code) ()
Version: master
Hardware: All All
: --- normal
Target Milestone: Future
Assignee: xamarininteractive
Depends on:
Reported: 2017-08-09 01:54 UTC by Miguel de Icaza [MSFT]
Modified: 2017-08-23 19:19 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 58656 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:

Description Miguel de Icaza [MSFT] 2017-08-09 01:54:43 UTC
I tried adding the "System.Reactive 3.1.1" package to the "Mono" version on the Mac, and while the System.Reactive is shown on the NuGet package list, nothing gets added automatically with the "#r" and I do not know what I could load.  I tried the obvious #r "System.Reactive", but it claims that it is not there.
Comment 1 Miguel de Icaza [MSFT] 2017-08-09 03:05:40 UTC
The same happens with the Mac (Full) mode.
Comment 2 Bojan Rajkovic [MSFT] 2017-08-18 17:37:06 UTC
This is a known issue with "metapackages" that do not have any actual assemblies in them--we've got an idea for a fix but it depends on some other work.

In the meantime, you can work around it for System.Reactive specifically by adding these `#r`'s:

#r "System.Reactive.Core"
#r "System.Reactive.Linq"

That should get you all the necessary APIs.
Comment 3 Bojan Rajkovic [MSFT] 2017-08-23 19:19:02 UTC
Another possible workaround for this bug: enable pre-release packages and install System.Reactive 4.0.0 previews. Per the Rx team, they've changed the way packages are built going forward so that all of the implementation is in System.Reactive and the other packages simply contain type forwarders.